Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 35 След.
Поиск наибольшего значения в таблице
 
Цитата
orB написал:
Вопрос зачем "СТРОКА(P1)"?
А чтоб не заниматься этим:
Цитата
orB написал:
просто заменил на 1 (соответственно у I места, на 2 у II места и т.д..
Вставил формулу и протянул
СТРОКА(?) как раз и занимается заменой 1 на 2 для второго места и т.д.
Пример для темы
выборка каждой 5 строки и данных из нее, выборка каждой 5 строки и данных из нее
 
=ИНДЕКС('план заказов'!B$3:B$28;ЦЕЛОЕ((СТРОКА(A2))*5)-9)
Количество людей пенсионного возраста (кому за 60 лет)
 
Crallt, в предыдущих темах Вас удовлетворили ответы?
удаление содержимого папки макросом
 
БМВ, СПАСИБО. то что надо.
Anchoret, спасибо. пригодится.
удаление содержимого папки макросом
 
здравствуйте. есть папка, которую надо очистить от возможно имеющихся папок и файлов.так как макросы не пишу, а только пользуюсь ими, то подобрал для выполнения этого действия два макроса.первый макрос удаляет папку со всем содержимым, а второй копирует папку с тем же именем на место удаленной папки. так и пользуюсь.
проблема в том, что запуск вместе первого и второго макроса не дает результат. только отдельно запуск первого макроса, а затем запуск второго макроса.есть ли возможность запустить сразу два макроса? или есть возможность написать макрос очистки без удаления папки?
Отобрать 10 наибольших значений в выделенном диапазоне и подтянуть данные из остальных стоблцов к отобранным ячейкам
 
в ячейку G2
Код
=ЕСЛИ($I2=$I1;ИНДЕКС(A$2:A$14;АГРЕГАТ(15;6;СТРОКА($A$1:$A$15)/($C$2:$C$15=$I2);2));ИНДЕКС(A$2:A$14;ПОИСКПОЗ($I2;$C$2:$C$14;0)))

протянуть на G2:K11. в ячейку I2
Код
=НАИБОЛЬШИЙ($C$2:$C$13;СТРОКА(I1))

работает при возможном равенстве максимум двух значений в столбце "обработано".
Не работают макросы в другом файле
 
Цитата
БМВ написал:
не пытаетесь решить проблему самостоятельно
как я решу, если макросами умею только пользоваться. макросы получил на этом форуме, за что спасибо и форуму и авторам.
Цитата
БМВ написал:
Чистой воды VBS скрипты
так и есть. получил как скрипт. был скриптом - стал макросом.  
Не работают макросы в другом файле
 
Hugo, The_Prist,  подключил библиотеку Microsoft Scripting Runtime. заработало.спасибо.
Не работают макросы в другом файле
 
здравствуйте. прошу помочь. скопировал два макроса в файл. макрос Content_for_etfs_convert отработал без проблем. после запускаю replaceTxts. выходит ошибка и выделяется fso As New FileSystemObject синим. в файле, с которого скопировал, работает как надо.может, какие то библиотеки надо подключить?

Код
Sub Content_for_etfs_convert()
Kill "D:\option programs\отбор\IN\*.*"
Kill "D:\option programs\отбор\OUT\*.*"
  Dim fso
  Set fso = CreateObject("scripting.filesystemobject"):  fso.CopyFolder "C:\Users\Администратор\Downloads\Stock\src\dist\downloads", "D:\option programs\отбор\IN"
 
Set fso = CreateObject("Scripting.FileSystemObject")
cPath = fso.GetParentFolderName(ThisWorkbook.FullName)
 
cPathIn = cPath & "\In\"
cPathOut = cPath & "\Out\"
 
Set Folder = fso.GetFolder(cPathIn)
For Each File In Folder.Files
   If fso.GetExtensionName(File.Name) = "txt" Then
      With fso.OpenTextFile(cPathIn & File.Name, 1, True)
         cIn = .ReadAll
         .Close
      End With
      cOut = vbCrLf & "DATE"
      arrL = Split(cIn, vbLf)
      For i = LBound(arrL) To UBound(arrL)
         If Len(arrL(i)) > 0 Then
            arrD = Split(arrL(i), ",")
            arrD(0) = Right(arrD(0), 2) & "." & Mid(arrD(0), 5, 2) & "." & Left(arrD(0), 4)
            For j = 1 To 4
               cnum = Replace(arrD(j), ".", ",")
               arrD(j) = Replace(CStr(Round(CDbl(cnum), 2)), ",", ".")
            Next
            cnum = Replace(arrD(6), ".", ",")
            arrD(6) = Replace(CStr(Round(CDbl(cnum), 0)), ",", ".")
            cOut = cOut & vbCrLf & Join(Array(arrD(0), arrD(1), arrD(2), arrD(3), arrD(4), arrD(6)), vbTab)
         End If
      Next
      With fso.OpenTextFile(cPathOut & File.Name, 2, True)
         .Write cOut
         .Close
      End With
   End If
Next

 
MsgBox "Ok"

End Sub
Sub replaceTxts()
    Dim fso As New FileSystemObject, curFolder As Folder, curFile As File
    folderPath = "D:\option programs\отбор\OUT\"
    Set curFolder = fso.GetFolder(folderPath)
    For Each curFile In curFolder.Files
        If Right(curFile.Path, 4) = ".txt" Then
            curFile.copy Replace(curFile.Path, ".txt", ".csv")
            curFile.Delete
        End If
    Next curFile
End Sub
копирование необходимых файлов
 
Nordheim, спасибо.  
копирование необходимых файлов
 
Sanja, спасибо. все стало на свои места. заработало.
копирование необходимых файлов
 
скачал архив с форума. распаковал. скопировал код в модуль файла txt.xlsm и запустил макрос. в итоге пусто в 567.
копирование необходимых файлов
 
Sanja, я, наверное, что то не так делаю. макрос отрабатывает без ошибок, но в папке 567 остается пусто. может, у кого получилось.
копирование необходимых файлов
 
добрый день. не могли бы помочь. как из папки 123 скопировать файлы, имена которых имеются в столбце I, в папку 567 .
Сохранить файлы в другой папке
 
Sanja, код работает как надо. спасибо.
Цитата
БМВ написал:
сами то как думаете?
я, как отложил excel месяца на три, так все и позабыл. так что без помощи форума сам не додумаюсь.
Сохранить файлы в другой папке
 
так не работает
Код
  fl = ActiveWorkbook.Path & "\" & "C:\200" & "\" & Cells(i, 3).Value & ".txt"
Сохранить файлы в другой папке
 
добрый день. есть макрос, который создает файлы тхт в папке. как указать для создания файлов тхт адрес другой папки? например, создавать файлы тхт в папке 200 по адресу C:\200.
Код
Sub TXT()
For i = 1 To Range("E2")
    fl = ActiveWorkbook.Path & "\" & Cells(i, 3).Value & ".txt"
    Open fl For Output As 1
         Print #1, Range("A1").Value
    Close 1
Next
End Sub
Как из нескольких листов(2,3,4) копировать автоматически строки в первый лист, если в этой строке есть определённая метка???
 
еще вариант формулами. может, пригодится кому
ввод квартальной цены по заданной продукции, arslantm80
 
.
Код
=ВПР(I4;$A$4:$E$9;ГПР(J4;$B$3:$E$3;1;0)+1;0)
ввод квартальной цены по заданной продукции, arslantm80
 
предложите новое название темы в сообщении. так и напишите:
предлагаю новое название: и напишите это новое название.
Создание списка выборкой из двух листов по нескольким условиям
 
.
Изменено: copper-top - 29 Ноя 2017 02:41:25
Как сгруппировать одинаковые значения с переносом зависимых ячеек?
 
b_alex, проверять не надо - опробуйте. если надо - пользуйтесь. например, первыми тремя формулами из четырех из cообщения #2.
Рисование отверстия в фигуре (замкнутой Полилинии)
 
delete
Изменено: copper-top - 27 Ноя 2017 03:14:25
Рисование отверстия в фигуре (замкнутой Полилинии)
 
Цитата
Megamen2 написал:
Нет ли более простого способа ?
не знаю простым ли способом покажется...
попробуйте на фигуре РАМКА пкм Начать изменение узлов.
или на фигуре КОЛЬЦО.
Изменено: copper-top - 27 Ноя 2017 02:58:46
Как сгруппировать одинаковые значения с переносом зависимых ячеек?
 
в А20:D20
Код
=ЕСЛИ(ЕТЕКСТ(B20);СТРОКА(A1);"")
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$14;АГРЕГАТ(15;6;СТРОКА($A$1:$A$49)/ЕНД(ПОИСКПОЗ($B$2:$B$14;$B$19:B19;0));1));"")
=ЕСЛИОШИБКА(ИНДЕКС($C$1:$N$10;ПОИСКПОЗ($B20;$B$1:$B$10;0);ПОИСКПОЗ(C$19;$C$1:$N$1;0));"")
=ЕСЛИОШИБКА(ИНДЕКС($D$2:$N$11;АГРЕГАТ(14;6;СТРОКА($D$1:$N$10)/($B$2:$B$10=$B20)/(D$2:D$10="да");1);СТОЛБЕЦ(A1));"")
если не ошибся
Как выводить перечень характеристик, соответствующих объекту, выбранному из списка?
 
то ли
Код
=ГПР(E$14;$E$4:$H$8;СТРОКА(A2);0)
Выделить единицей строки по двум условиям
 
приятных снов. :)  
Выделить единицей строки по двум условиям
 
формула массива
Код
=ЕСЛИ(B1="s/l";0;--(A1>ЕСЛИ(0=МИН(ЕСЛИ(($B$1:$B1="s/l");ЕСЛИ($C$1:$C1=C1;$A$1:$A1)));9^9;МИН(ЕСЛИ(($B$1:$B1="s/l");ЕСЛИ($C$1:$C1=C1;$A$1:$A1))))))
или
Код
=ЕСЛИ(B1="s/l";0;--(A1>--МИН(ЕСЛИ(($C$1:$C1=C1);ЕСЛИ($B$1:$B1="s/l";$A$1:$A1);9^9))))
как вводить формулы массива и скрывать нули ищите на форуме.
Изменено: copper-top - 26 Ноя 2017 19:51:05
Выделить единицей строки по двум условиям
 
Цитата
solnce60 написал:
к сожалению, не получилось. Выдает одни нули и ошибки.
если excel 2010+, то попробуйте (ввести формулу и протянуть ее) пять раз.
Выделить единицей строки по двум условиям
 
если не ошибся. для excel 2010+
Код
=ЕСЛИОШИБКА(--(A1>АГРЕГАТ(15;6;$A$1:$A1/($B$1:$B1="s/l")/($C$1:$C1=C1);1));0)
можно еще спереди добавить
Код
ЕСЛИ(B1="s/l";0;
Изменено: copper-top - 26 Ноя 2017 12:14:59
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 35 След.
Наверх