Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Как закрасить текст в outlook при отправке его из excel?
 
Добрый день.
Замучился с такой проблемой, есть макрос который отправляет данные из файла excel в outlook по списку почтовых адресов.
Так вот в этих данных одну из строк мне нужно закрасить в желтый цвет, но никакие манипуляции мне не помогают.
Код ниже, отправляет по адресу текст:
"Добрый день
Данные:"

Вопрос - что нужно прописать в коде, чтобы пришло письмо в котором слово строчка "Данные:..." была закрашено в желтый цвет.
Код
Sub send_email()
Dim olApp As Object
Dim olMailItm As Object
Dim iCounter As Integer
Dim Dest As Variant
Dim SDest As String

strSubj = "тема письма"
On Error GoTo dbg
Set olApp = CreateObject("Outlook.Application")
For iCounter = 2 To WorksheetFunction.CountA(Columns(1))
Set olMailItm = olApp.CreateItem(0)
strBody = ""
useremail = Cells(iCounter, 1).Value
FullUsername = Cells(iCounter, 2).Value
b = Cells(iCounter, 3).Value
c = Cells(iCounter, 4).Value

strBody = strBody & "Добрый день!" & vbCrLf & vbCrLf
strBody = strBody & "Данные:  " & c

olMailItm.To = useremail
olMailItm.Subject = strSubj
olMailItm.BodyFormat = 2
olMailItm.Body = strBody
olMailItm.Send
Set olMailItm = Nothing
Next iCounter
Set olApp = Nothing
dbg:
If Err.Description <> "" Then MsgBox Err.Description
End Sub
Вычисление значения при множественном условии
 
Добрый день.
Есть задача:

Если значения в ячейках A1/B1 < 1, то в ячейку C1 должна подставляться цифра 0.
Если значения в ячейках A1/B1 от 1 до 2, то в C1 подставляется 1
Если значения в ячейках A1/B1 от 2 до 3, то в C1 подставляется 2
Если значения в ячейках A1/B1 > 3, то в C1 подставляется  3

Это вроде легко выполнить
Код
=ЕСЛИ(A1/B1<1;0;ЕСЛИ(A1/B1<2;1;ЕСЛИ(A1/B1<3;2;ЕСЛИ(A1/B1>3;3;))))

Но далее сюда вводится условие, что если значение в ячейке D1 является отрицательным, то значения в ячейке C1 полностью меняются и меняется условие.
То есть, если D1 имеет отрицательное значение, должно выполняться следующее условие:

Если значения в ячейках A1/B1 < 1, то в ячейку C1 должна подставляться цифра 0.
Если значения в ячейках A1/B1 от 1 до 2, то в C1 подставляется 5
Если значения в ячейках A1/B1 от 2 до 3, то в C1 подставляется 6
Если значения в ячейках A1/B1 > 3, то в C1 подставляется  7

Не знаю как сделать это, может кто-то поможет
Вычисление сумм по дате.
 
Доброго дня.
Сломал голову, надеюсь вы поможете.

В файл такого вида:
номер дата началадата окончания 01.01.1602.01.16 03.01.16 04.01.16 ВИД
первый 01.01.16 04.01.16 1 2 3 4 БЕЛЫЙ
второй 02.01.16 03.01.16 54 3 2 БЕЛЫЙ
третий 03.01.16 05.01.164 3 2 1 КРАСНЫЙ
четвёртый ЖЕЛТЫЙ
...
Я вычислил сумму по номерам в датах от начала до окончания.
Например. сумма номера "первый" в дате от 01.01.16 - 04.01.16 имеет сумму 10 (сумма ячеек B4:B7) и так далее.

Вроде это я решил в таком виде:
Код
=ЕСЛИОШИБКА(СУММ(ДВССЫЛ(СЦЕПИТЬ(АДРЕС(ПОИСКПОЗ(A3;A:A);ПОИСКПОЗ(D3;$1:$1;0));":";АДРЕС(ПОИСКПОЗ(A3;A:A);ПОИСКПОЗ(E3;$1:$1;0)))));"Нет")

Только первая часть головоломки.

Далее сама головоломка.
Нужно в огромный файл вида (ниже):
Подставить значения таблицы которая выше и вычислить сумму по датам.
Пример:
Значение из ячейки A3 (таблица 1)

Вид: "белый"
Дата: "01.01.16 - 04.01.16"

Просканировать всю вторую таблицу по датам в примере (от 01.01 - 04.01 по параметру белый) и вычислить сумму, то есть те значения что я выделил и подчеркнул во второй таблице.

И таких значений много.

номер вид01.01.16 02.01.16 03.01.16 04.01.16 05.01.1606.01.16
1 белый 12 3 4 5 6
2 красный2 1 1 1 1 2
3 белый3 3 3 2 2 2
4 красный 1 11 1 1 1
5 красный 3 2 1 1 2 3

Если найдется кто может помочь, буду благодарен.
Страницы: 1
Наверх