Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 След.
Замена старого текста на новый
 
не получается из-за кавычек в тексте..
вариант с доп ячейкой
Перенос ячеек со смещением по столбцам, Суммирование столбцов со смещением
 
тема: Поиск в массиве по условию.

в C3
Код
=ЕСЛИОШИБКА(ИНДЕКС($K$3:$M$6;ПОИСКПОЗ($A3;$I$3:$I$6;0);ПОИСКПОЗ(C$2;$K$2:$M$2;0));"")

Но таких баянов на форуме тысячи..
Выборка данных
 
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('1'!$C$1:$C$8;НАИМЕНЬШИЙ(ЕСЛИ('1'!$B$3:$B$8="ЗИФ2";СТРОКА('1'!$B$3:$B$8));ЧСТРОК($A$1:$A1)));"")
Заполнить пустые ячейки значениями предыдущих ячеек
 
как вариант, формулой массива
Код
=ИНДЕКС($A$1:$A2;МАКС(ЕСЛИ($A$2:$A2<>"";СТРОКА($A$2:$A2))))
СУММЕСЛИ теряет "0" в текстовом критерии
 
или без массива
Код
=СУММПРОИЗВ(--($B$2:$B$7=$E4&"");$A$2:$A$7)
Выборка определённого количества данных из диапазона
 
массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$1:$D$32;НАИМЕНЬШИЙ(ЕСЛИ($D$25:$D$32<>"";СТРОКА($A$25:$A$32));СТРОКА($A1)));"")
Выборка определённого количества данных из диапазона
 
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$1:$C$9;НАИМЕНЬШИЙ(ЕСЛИ($C$2:$C$9<>"";СТРОКА($B$2:$B$9));СТРОКА($A1)));"")
Поиск последней позиции в списке по условию
 
массивные
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$F$8;ПОИСКПОЗ(МАКС(ЗНАЧЕН(ПРАВСИМВ($A$3:$A$8;5)));ЗНАЧЕН(ПРАВСИМВ($A$3:$A$8;5));0);ПОИСКПОЗ($J4;$B$2:$F$2;0));"")

или
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$F$8;ПОИСКПОЗ(;ЕСЛИ($A$3:$A$99<>"";));ПОИСКПОЗ($J4;$B$2:$F$2;0));"")
Умножение по условию
 
массивная
Код
=СУММ(ЕСЛИ(($A$2:$A$10=$A14)*($B$2:$B$10=1);C$2:C$10*5)+(ЕСЛИ(($A$2:$A$10=$A14)*($B$2:$B$10>2);C$2:C$10*1*МАКС(ЕСЛИ(($A$2:$A$10=$A14)*($B$2:$B$10=2);C$2:C$10*2)))))
Удаление дубликатов
 
на формулах
Поиск значения на одном листе и вывод на другой
 
еще вариант
Макрос поиска доменов с ошибкой в email адресе
 
попробуйте, может быть вам подойдет такое решение
Поиск всех позиций в заказе
 
как вариант
Копирование значений нескольких столбцов при совпадении значений в ключевых столбцах
 
Может быть вы выложите свой файл-пример, на нем и подскажем
Найти в ячейке любое слово из списка, Помогите укоротить формулу
 
формула массива
Код
=СУММ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК($A$6:$P$6;$R$2);)<>0;1))
Изменено: MOTO - 24 Июл 2018 15:46:34
Вставка данных к совпадающим значениям
 
странно, странно
Вставка данных к совпадающим значениям
 
попробуйте
Примечания не всплывают при наведении курсора на ячейку, параметр Параметры-Экран-только индикаторы (и всплывающие примечания) выставлен
 
попробуйте, может подойдет
Код
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    If Not LastCommentCell Is Nothing Then
        If Not LastCommentCell.Comment Is Nothing Then LastCommentCell.Comment.Visible = False
    End If
    If Not Target.Comment Is Nothing Then
        Target.Comment.Visible = True
        Set LastCommentCell = Target
    End If
End Sub
Сумма в ячейках по условию
 
может так?
Сумма двух ячеек по условию, Какая должна быть формула, если значения не в столбик, а в строку?
 
Код
=ЕСЛИ(СЧЁТЕСЛИ($D$10:$D$17;$G2)>0;$H2+$I2;"")
Изменено: MOTO - 20 Июл 2018 03:57:32
Как вернуть данные из массива по условию
 
такой вариант
Тема: Как вернуть данные из массива функцией ИНДЕКС по условию
Проценка магазина з/ч, Создать файл
 
актуально?, могу взять если не дэмп.
Копирование данных в таблицу из поименованных таблиц внутри одной книги по условию, Создание макроса или формулы по переносу данных в таблицу из поименованных таблиц внутри одной книги по условию
 
проверяйте, (формула массива, вводится через Ctrl+Shft+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС('Поименованные таблици'!$B$1:$H$999;МИН(ЕСЛИ('Поименованные таблици'!$B$1:$H$999=$D$4;СТРОКА('Поименованные таблици'!$B$1:$H$999)))+СТРОКА(A2)-1;СТОЛБЕЦ(A1));"")
Периодическое суммирование ячеек при условии, Периодическое суммирование ячеек при условии
 
maximus-mag, добавите файл - пример, вам помогут
Сумма по динамическому условию, Вывести сумму из массива по условию
 
еще вариант, формула массива
Код
=СУММ(ЕСЛИ($F$2:$H$2=$B$3;$F$3:$H$5))
Как посчитать прибыль/убыток сделки?
 
у меня результат вычисления
Код
-385673
Как посчитать прибыль/убыток сделки?
 
Формула массива, вводится сочетанием клавиш Ctrl+Shft+Enter
Код
=СУММ(ЕСЛИ(C:C="Продажа";D:D*E:E))-СУММ(ЕСЛИ(C:C="Купля";D:D*E:E))
Как посчитать прибыль/убыток сделки?
 
Попробуйте так
Код
=СУММПРОИЗВ(--($C$2:ИНДЕКС($C$2:$C$9999;ПОИСКПОЗ("яяяяя";$C$2:$C$9999))="Купля");D2:ИНДЕКС($D$2:$D$9999;ПОИСКПОЗ("яяяяя";$C$2:$C$9999))*E2:ИНДЕКС($E$2:$E$9999;ПОИСКПОЗ("яяяяя";$C$2:$C$9999)))-СУММПРОИЗВ(--($C$2:ИНДЕКС($C$2:$C$9999;ПОИСКПОЗ("яяяяя";$C$2:$C$9999))="Продажа");D2:ИНДЕКС($D$2:$D$9999;ПОИСКПОЗ("яяяяя";$C$2:$C$9999))*E2:ИНДЕКС($E$2:$E$9999;ПОИСКПОЗ("яяяяя";$C$2:$C$9999)))

Последняя строка в полях: Операция, Цена, Кол-во "должна быть заполнена равномерно", иначе формула вернет ошибку
Изменено: MOTO - 30 Июн 2018 18:08:58
Поиск значения в списке
 
в столбце H решение
Поиск значения в списке
 
вариант
Страницы: 1 2 3 4 5 6 7 8 След.
Наверх