Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 37 След.
Заполнить ячейки указанному по количеству месяцев
 
Код
=(A4<=B$1)*B$2
Алексей М.
Поиск значения одной ячейки при котором в другой значение становитcя отрицательным
 
Нужен файл-пример.
Алексей М.
Определить количество строк для вывода текста на печать
 
Картинки не для этого форума. Покажите файл-пример в формате Excel
Экспериментируйте с макрофункцией ПОЛУЧИТЬ.ЯЧЕЙКУ(17; ссылка)
Изменено: АlехМ - 9 июл 2020 10:22:58
Алексей М.
Специальное округление, если последняя цифра 5
 
Код
=ОКРУГЛ(A1-ОСТАТ(ОТБР(A1)+1;2)%;)
=ОКРУГЛ(A1-(ОСТАТ(A1;2)<1)%;)
Изменено: АlехМ - 8 июл 2020 15:19:29
Алексей М.
Специальное округление, если последняя цифра 5
 
так подойдет?
Код
=ОТБР(A1)+ОСТАТ(ОТБР(A1);2)*(--ПРАВБ(A1)=5)+ОКРУГЛ(ОСТАТ(A1-1%;1);)
Алексей М.
Специальное округление, если последняя цифра 5
 
числа больше или равные 10 будут?
Алексей М.
Специальное округление, если последняя цифра 5
 
Покажите файл-пример с разными числами и желаемый результат.
Алексей М.
Разница между различными датами и временем
 
Код
=ТЕКСТ(B3-A3;"[<1]ч:мм:сс;Д \дн. ч:мм:сс")
Изменено: АlехМ - 4 июл 2020 15:08:30
Алексей М.
Вывести все названия месяцев из заданного периода
 
Опоздал с темой, но жалко решение не использовать.
Код
=ЕСЛИ(СТРОКА()>РАЗНДАТ(A$1;B$1;"M")+1;"";ДАТА(ГОД(A$1);МЕСЯЦ(A$1)+СТРОКА();))
Алексей М.
Быстрое выделение колонок с одинаковым названием
 
В вашей таблице нет конца столбцам. Непонятно зачем копировать через столбец и куда-то это вставлять. Проще копировать всю таблицу.
Если нужно только удалить данные из выбранных столбцов и на листе размещать 1 месяц, ~60 столбцов, то можно сделать гиперссылку.
Код
=ГИПЕРССЫЛКА("#"&"C:C;E:E;G:G;I:I;K:K;M:M;O:O;Q:Q;S:S;U:U;W:W;Y:Y;AA:AA;AC:AC;AE:AE;AG:AG;AI:AI;AK:AK;AM:AM;AO:AO;AQ:AQ;AS:AS;AU:AU;AW:AW;AY:AY;BA:BA;BC:BC;BE:BE;BG:BG;BE:BE;BG:BG;BI:BI";"выручка")
См. пример.
Алексей М.
Номер исходного столбца, в зависимости от значения ячейки.
 
БМВ, произведений получим 0
Алексей М.
Номер исходного столбца, в зависимости от значения ячейки.
 
Сумма произведений логического выражения таблица равна цифровому значению и значений функции СТОЛБЕЦ(), аргумент которой таблица.
Алексей М.
Работа с числом, идущим в столбце после первичного появления числа, приобретающиего в столбце повтор.
 
Это формула массива, ввод Ctrl+Shift+Enter
Изменено: АlехМ - 2 июл 2020 19:49:18
Алексей М.
Работа с числом, идущим в столбце после первичного появления числа, приобретающиего в столбце повтор.
 
Вдруг правильно.
Формула отмечает ячейку, которая равна конкретному числу из столбца В, а предыдущее значение является первым повторяющимся значением в столбце А
Код
=И(ИНДЕКС(A$3:A$22;Ч(ИНДЕКС(ПОИСКПОЗ(1=1;СЧЁТЕСЛИ(A$3:A$22;A$3:A$22)>1;)+{0:1};)))=A2:A3)*(A3=B$2)
Алексей М.
Работа с числом, идущим в столбце после первичного появления числа, приобретающиего в столбце повтор.
 
deinstalation, почему 1 в ячейке В9?
Алексей М.
Счёт количества ячеек по датам, Создание новой таблицы в результате подсчёта количества ячеек по дате
 
Код
=СУММПРОИЗВ(Ч(ОТБР(A$2:A$400)=D2))
Алексей М.
Найти максимальное значение по двум условиям
 
БМВ, надо добавить еще по одному.
Алексей М.
Найти максимальное значение по двум условиям
 
Формула массива
Код
=ЕСЛИ(B2+C2%%=МАКС((A2=A$2:A$30)*(B$2:B$30+C$2:C$30%%));1;"")

Ошибки тоже заметил
Алексей М.
Проставление отметки об оплате
 
Цитата
Mershik написал:
вариант вытащить номер договора
Зачем? Все договора ужу есть на втором листе. Их ищем в длинной текстовой строке.
Рабочий вариант в сообщении №5
Пример плохой, ни одного совпадения договоров.
Алексей М.
Проставление отметки об оплате
 
Цитата
Николай Николаев написал:
если номер из назначения платежа столбца A есть
должна работать формула массива
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК(" "&'База договоров'!A$7:A$76&" ";" "&'База Оплаты'!A2&" ")));"да";"нет")
Изменено: АlехМ - 30 июн 2020 10:56:57
Алексей М.
Отметить неделю в списке дат
 
Покороче формула. Массивная
Код
=И(C3:C8=C2+{1:2:3:4:5:6};A3:A8=A2)+(C2=Ч(C1)+(A1=A2))*(D1=1)
Алексей М.
Рассчитать формулы без знака "="
 
Код
=ПОДСТАВИТЬ(СУММПРОИЗВ(ПОИСКПОЗ(C18:C24;C5:C11;)*100^(7-B18:B24));0;",")
Может быть так?
Алексей М.
Отметить неделю в списке дат
 
Кросс
Алексей М.
Рассчитать формулы без знака "="
 
а почему нельзя так написать
Код
=СЦЕПИТЬ(C18;",";C19;",";C20;",";C21;",";C22;",";C23;",";C24)
Алексей М.
Рассчитать формулы без знака "="
 
Непонятно что нужно получить в D27
Вашу массивную формулу можно заменить на массивную
Код
=ВПР(C18&"";C$5:D$12&"";2;)
Алексей М.
попадание времени в интервал, необходимо понять попадает ли время в график
 
Цитата
Pr0v0kat0r написал:
что-то не получается
В сообщении №6 файл есть.
А2<B2, то к А2 прибавляем 1 день или 24 часа
Алексей М.
попадание времени в интервал, необходимо понять попадает ли время в график
 
Цитата
БМВ написал:
я б не спешил с помощью.
Не понял причину. Может быть название темы с маленькой буквы?
Алексей М.
попадание времени в интервал, необходимо понять попадает ли время в график
 
Цитата
lostandleft написал:
тоже самое
Ошибаетесь.
В строке 16 результат отличается от вашего неверного.
Изменено: АlехМ - 26 июн 2020 09:36:56
Алексей М.
попадание времени в интервал, необходимо понять попадает ли время в график
 
Код
=ЕСЛИ((A2+(A2<B2)>B2)*(A2+(A2<B2)<C2+(C2<B2));"да";"нет")
Алексей М.
Обрезать ячейку до определенного значения
 
Чайник1, Может быть ввод не массивный?
В моей формуле ЛЕВБ() замените на ЛЕВСИМВ(). В английском варианте будет формула короче.
Изменено: АlехМ - 26 июн 2020 08:27:40
Алексей М.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 37 След.
Наверх