Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 299 След.
Как не перебирать все условия, а выйти после первой ИСТИНЫ
 
Цитата
Сергей Евдокимов написал:
Макрос с "Case" - 5 минут 09 секунд
Макрос с "ElseIf" - 5 минут 14 секунд.
ипануццо
а кто выиграл?
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Как не перебирать все условия, а выйти после первой ИСТИНЫ
 
Цитата
Marat Ta написал:
Exit For
самое то!!! остальные ячейки проверять не нужно, нашли одну и отлично!
Marat Ta,
как бы это по-мягче...
если подобные советы вы раздавали бы где -то на городской площади, то уходили бы домой далеко не в самой чистой одежде.
интернет, конечно гораздо более безопасное место с этой точки зрения)) тут и не такое можно написать (практически безнаказанно)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Среднее по двум условиям исключая 0, Исключение 0х значений из расчета усредненного показателя
 
однако...
два условия пишем, а третье что мешает?
добавьте условие 3, посчитает без нулей)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Выделить те значения в строке, которым соответствует цифра в столбце.
 
Цитата
Валентин Литвинов написал:
Так вот, необходимо выделить желтым те значения в строке, которым соответствует цифра в столбце
так вот, необходимо обьяснить что такое "соответствует", чтобы каждый не придумывал себе сам что чему соответсвует

открывайте файл, жмите F9
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Управление расположением графиков из VBA
 
aigy3,
включили макрорекордер, взяли график мышкой за рамку и положили чуть в стороне от исходного положения
выключили макрорекордер
посмотрели в записанный им макрос и там...
видно на основании чего картинка с графиком получила НОВЫЕ КООРДИНАТЫ расположения на листе
удачи!
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Окрашивание ненужных ячеек условным форматированием при вводе значений", Подкрашивание условным форматированием ячеек при вводе текста
 
с строк 12 и дальше я не снес ваши условные форматы
в этом вложении - это исправлено
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Окрашивание ненужных ячеек условным форматированием при вводе значений", Подкрашивание условным форматированием ячеек при вводе текста
 
на листе СП в строках начиная с колонки 4 и дальше перечисляете какие колонки листа CX_АПС должны быть подсвечены)
после выбора значения в Д - они подсветятся
во вложенном файле №№ колонок заданы только для ВУОС и Ручной извещатель
Изменено: Ігор Гончаренко - 16 апр 2021 23:51:27
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Управление расположением графиков из VBA
 
делайте все это руками
включите макрорекордер
изучая содержимое записанных макросов можете получить ответы не только на те вопросы, что вы уже задали, но и на все остальные, которые у вас есть
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Ввод значения в ячейку по условию
 
никак
или
макросом
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Печать листов в таком порядке, чтобы можно было сложить книжку.
 
сначала 1 лист, потом 26 - это точно шахматный порядок?
если порядок не шахматный - к чему упоминание о шахматном порядке в заголовке?
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Найти повторы значений в обратном порядке и удалить дубли
 
можно
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Найти повторы значений в обратном порядке и удалить дубли
 
))
Код
=СУММПРОИЗВ((R2C1:R[-1]C1=RC[-3])*(R2C2:R[-1]C2=RC[-4]))
фильтруйте 1, удаляйте
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Найти повторы значений в обратном порядке и удалить дубли
 
Код
=СУММПРОИЗВ((R2C1:R3451C1=RC[-3])*(R2C2:R3451C2=RC[-4])*СТРОКА((R2C1:R3451C1)))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Случайный выбор с ранжированием
 
)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Случайный выбор с ранжированием
 
а у каких значений какой ранг?
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Случайный выбор с ранжированием
 
реально, а что именно?
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Проверка условия на большом диапазоне ячеек
 
вы все правильно написали - способ абсолютно аналогичный (и, понятно, он есть)
Изменено: Ігор Гончаренко - 16 апр 2021 06:58:22
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Пересчёт линейных размеров Длина*Ширина, находящихся внутри текста, в метры квадратные.
 
Код
Function Square#(s$)
  Dim re
  Set re = CreateObject("VBScript.RegExp")
  re.Pattern = "\*(\d+\*\d+)"
  If re.test(s) Then Square = Evaluate(re.Execute(s)(0).submatches(0)) / 1000000
End Function
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Значения функции двух переменных, представленные в табличной форме
 
в Д5 посчитано 38, а вам сколько нужно?
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Проверка условия на большом диапазоне ячеек
 
Код
Private Sub Worksheet_Change(ByVal Target As Range)
  If Target.Row <> 4 Then Exit Sub
  If Target.Column < 2 Or Target.Column > 13 Then Exit Sub
  Application.EnableEvents = False
  Target.Offset(3) = Target.Offset(3) + 1
  Target.Offset(5) = 0
  Application.EnableEvents = True
End Sub
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Поиск и копирование столбцов с определенным значением
 
см.вложение
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Значения функции двух переменных, представленные в табличной форме
 
полученная таблица вас устраивает - нет ошибки
не устраивает, конкретно что не устраивает?
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Скрытая отправка активной рабочей книги электронной почтой
 
ответ см. в след. теме
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Значения функции двух переменных, представленные в табличной форме
 
а есть информация сколько % брони выдержат 1 выстрел
и сколько нужно иметь % брони чтобы выдержать 5 или 6 выстрелов
любая информация подойдет
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Цикл создания новых книг на основании инфорамации с текущего файла VBA
 
в xlsx макросы не живут(((
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Заполнить таблицу данными из другой таблицы используя справочник условий
 
Цитата
Семен Иванов написал:
а я наоборот, взаимосвязь вижу.
а в чем она выражается?
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Заполнить таблицу данными из другой таблицы используя справочник условий
 
Цитата
vikttur написал:
Несколько лет активности
с этим главное не перегнуть
я честно пытался понять чем между собой связаны данные на 3-х листах, но связи не нашел(((
мало того...
пытаюсь понять, что посчитано формулами и ни одного решения не понял((((( ни одного!
нужно подвязывать с такой активностью
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Определить меньшее число из двух и рассчитать процент от третьего
 
Код
=ЕСЛИ(B6<МИН(B1;B3)*0.15;"да";"нет")
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Цикличное копирование данных из одной ячейки в другую и удаление лишних строк
 
Цитата
Дмитрий Парфенов написал:
Что там пересчитывать?
а почему не пересчитываете сами, раз там нечего пересчитывать?
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Скрытая отправка активной рабочей книги электронной почтой
 
это ерунда, что в Outlook сохранилось
куда
кому
и что
было отправленно, главное - чтобы скрытно?
Код
.Attachments.Add ThisWorkBook.FullName
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 299 След.
Наверх