Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Поиск даты в формате МЕСЯЦ()&ГОД() в диапазоне дат, Оптимизация поиска
 
PooHkrd, Да, похоже на истину.
АlехМ, тогда прошу прощения, был не прав.
Поиск даты в формате МЕСЯЦ()&ГОД() в диапазоне дат, Оптимизация поиска
 
АlехМ, Например, изменил значение ячейки A2 на 1/28/2017 (28 Января 2017), итого: формулы по прежнему выводят ответ: "Да". При этом в диапазоне B2:B35 нет дат за январь 2017.
Поиск даты в формате МЕСЯЦ()&ГОД() в диапазоне дат, Оптимизация поиска
 
PooHkrd, Ваш вариант работает.
Всем спасибо большое! :)  
Поиск даты в формате МЕСЯЦ()&ГОД() в диапазоне дат, Оптимизация поиска
 
АlехМ, ошибся то что назвал так столбец A.
В ячейке A2 будет дата не в формате МЕСЯЦ()&ГОД(), там может быть любая дата в привычном формате: 3/26/2018 (у меня англ. вариант дат). Т.е. преобразований даты в текст не требуется.

Попробовал Ваши обе формулы, к сожалению на дату с апрелем 2017, формула также ответила "Да", при этом в диапазоне апрельской даты нет. На этапе вычисления Вашей формулы заметил, что она обрабатывает не даты, а "ММГГГГ" и на любое значение выведет: Да. А третья формула вывела: "Да, Нет".  
Поиск даты в формате МЕСЯЦ()&ГОД() в диапазоне дат, Оптимизация поиска
 
Добрый день!

Прошу помочь с оптимизацией поиска даты в формате МЕСЯЦ()&ГОД() в диапазоне с датами.
0. Задача: если в массиве (B1:B34) есть хоть одна дата за февраль 2017, то если указать дату в ячейке A2: 02/%ЛЮБОЙ_ДЕНЬ%/2017, то формула выведет "Да", хоть и конкретно такой даты в массиве нет.
1. Очевидный способ - достроить вспомогательный столбец (C2:C35), который будет преобразовывать дату (A2) из диапазона (B1:B34) в нужный формат (например, МЕСЯЦ()&ГОД())
2. Формат такой выбрал, поскольку он самый простой, пробовал использовать: ДАТА(ГОД(),МЕСЯЦ(),1), но МЕСЯЦ()&ГОД() выглядит проще, т.е. привязки к формату нет.
3. Ну и сама формула поиска/подсчета:
Код
=ЕСЛИ(СЧЁТЕСЛИ(C2:C35,МЕСЯЦ(A2)&ГОД(A2))>0,"Да","Нет")
4. Пробовал сразу обращаться к массиву B1:B34, с помощью: МЕСЯЦ(B1:B34)&ГОД(B1:B34), но либо формула берет только первое значение из массива дат, либо возвращает ошибку.

Вопрос: есть возможность избежать создания вспомогательного столбца C?
Файл прикрепил.

P.S. Даты могут быть не упорядочены. Пустых ячеек не будет. Excel 2016.

Спасибо!
Изменено: andrewmr - 26 Мар 2018 10:29:17
Количество месяцев в диапазоне с датами, оптимизация способа подсчета
 
a.i.mershik, Хм, этот вариант вроде не учитывает то, что данных может попросту не быть за месяц (а формула его/их посчитает), а то и более. С датой от 2014 года, насчитала мне 49 месяцев :D
Цитата
andrewmr написал:
Отнять последнюю дату от первой не вариант - данных с датами может не быть как месяц так и более.
Мне Ваш первый вариант больше нравится. Спасибо еще раз 8)  
Изменено: andrewmr - 19 Мар 2018 16:38:25
Количество месяцев в диапазоне с датами, оптимизация способа подсчета
 
Немного изменил Вашу формулу:
Код
=СУММ(ЕСЛИ(ЧАСТОТА(ДАТА(ГОД(A2:A26),МЕСЯЦ(A2:A26),1),ДАТА(ГОД(A2:A26),МЕСЯЦ(A2:A26),1))>0,1))
На всякий случай прикреплю итоговый файл.

Спасибо всем большое! :)  
Количество месяцев в диапазоне с датами, оптимизация способа подсчета
 
Добрый день!

Прошу помочь с оптимизацией способа подсчета количества месяцев из диапазона с датами.
1. Задача: подсчитать количество месяцев из диапазона A:A;
2. Диапазон A:A содержит дату и время;
3. Найден способ с созданием вспомогательного столбца B, с формулой: =МЕСЯЦ(%ЯЧЕЙКА ИЗ СТОЛБЦА A%)
4. Далее по столбцу B находим кол-во уникальных значений (ячейка E1): =СУММ(ЕСЛИ(ЧАСТОТА(B:B,B:B)>0,1))

Вопрос: есть возможность избежать создания вспомогательного столбца B?
Файл прикрепил.

P.S. Даты могут быть не упорядочены. Пустых ячеек не будет.
Отнять последнюю дату от первой не вариант - данных с датами может не быть как месяц так и более.
Excel 2016. Использовать макросы и фильтры для таблицы не хотелось бы.

Спасибо.
Изменено: andrewmr - 19 Мар 2018 15:32:20
Страницы: 1
Наверх