Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 68 След.
Странное объединение запросов в Power Query. Внешнее соеднинение слева не работает как ВПР
 
Цитата
PooHkrd написал:
Без try
я знаю что ошибки в Excel не отразятся. добавил чтоб у автора темы не возникло вопросов - что это за error, а про знак вопроса совсем забыл :)  
Изменено: artyrH - 21 Янв 2020 16:02:05
По вопросам из тем форума, в личку писать только платежеспособным личностям
Странное объединение запросов в Power Query. Внешнее соеднинение слева не работает как ВПР
 
Veniamin Loginov, попробуйте так
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    Merge = Table.NestedJoin(Источник,{"Строки"},Таблица2,{"Строки 2"},"Таблица2",JoinKind.LeftOuter)
in
    Table.AddColumn(Merge, "впр", each try [Таблица2]{0}[Значния 2] otherwise null)
По вопросам из тем форума, в личку писать только платежеспособным личностям
Перенести данные из документа Word состоящий из надписей в таблицу Excel
 
sfs, в принципе можно сохранить файл в pdf и в Power Bi обработать. затем скопировать в Excel
не айс конешно, но от части ручной работы избавило бы
второй шаг можно закомментировать.
Код
let
    Источник = Pdf.Tables(File.Contents("C:\abc\2018_1\2018_1.pdf")),
    #"второй шаг" = Table.SelectRows(Источник, each  Text.Contains([Name], "(Page")),
    #"Добавлен пользовательский объект1" = Table.AddColumn(#"второй шаг", "Count", each Record.FieldCount([Data]{0})),
    Условн = Table.AddColumn(#"Добавлен пользовательский объект1", "a", each if [Count] = 4 then  Table.RenameColumns(Table.CombineColumns([Data],{"Column2", "Column3"},Combiner.CombineTextByDelimiter(" ", QuoteStyle.None),"Column2"),{{"Column4", "Column3"}}) else if [Count] = 5 then  Table.RenameColumns(Table.CombineColumns([Data],{"Column2", "Column3"},Combiner.CombineTextByDelimiter(" ", QuoteStyle.None),"Column2"),{{"Column5", "Column3"}}) else if [Count] > 5 then Table.RenameColumns(Table.AddColumn([Data], "Column", each Text.Combine(Record.FieldValues(_)," "))[[Column]],{{"Column", "Column1"}}) else [Data])[[a]],
    #"Развернутый элемент a" = Table.ExpandTableColumn(Условн, "a", {"Column1", "Column2", "Column3"})
in
    #"Развернутый элемент a"
По вопросам из тем форума, в личку писать только платежеспособным личностям
Размер (объём) папки с файлами в таблице
 
в Power Query
работает медленно. размер в Mb
По вопросам из тем форума, в личку писать только платежеспособным личностям
Фильтрация списка по ключевому слову
 
bigfoot, формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$1:C$700;АГРЕГАТ(15;6;СТРОКА($C$1:$C$510)/ЕЧИСЛО(ПОИСК("москв";$E$1:$E$503));СТРОКА(C1)));"")
По вопросам из тем форума, в личку писать только платежеспособным личностям
Мониторинг цен и остатков.
 
Ermakov_dm, кто же за 100 рублей вам делать будет? :D  
По вопросам из тем форума, в личку писать только платежеспособным личностям
Подсветить повторы в столбце по двум условиям
 
hlm, в теме же есть решение
По вопросам из тем форума, в личку писать только платежеспособным личностям
Автоматическая расстановка мест в турнирной таблице, Прошу подсказать.
 
.
По вопросам из тем форума, в личку писать только платежеспособным личностям
Подсветить повторы в столбце по двум условиям
 
Цитата
hlm написал:
чем пользоваться то?)
так я же вам ссылку давал. вы хотя бы пример-скриншот закинули бы в тему - я бы вам в Photoshope сделал бы. а так вы пример прям на странице темы выдали, вот и решил я прям на странице темы.
без обид конешно. а вы в правилах были? пункт 2.3 видели?
По вопросам из тем форума, в личку писать только платежеспособным личностям
Автоматическая расстановка мест в турнирной таблице, Прошу подсказать.
 
Цитата
SLONik24 написал:
чтобы пустая ячейка не воспринималась, как место
массивная
Код
=ЕСЛИОШИБКА(РИМСКОЕ(ЕСЛИ(G41="";"";ПОИСКПОЗ(СУММ(ЕСЛИ($G$41:$G$52<>0;($G$41:$G$52>G41)/СЧЁТЕСЛИ($G$41:$G$52;$G$41:$G$52)))+1;{1;2;3};)));"")
По вопросам из тем форума, в личку писать только платежеспособным личностям
Большой файл медленно работает
 
Цитата
vlad_d написал:
удалить столбцы с формулами
как будто кроме формул удалять нечего :)  
По вопросам из тем форума, в личку писать только платежеспособным личностям
Подсветить повторы в столбце по двум условиям
 
hlm,пользуйтесь
По вопросам из тем форума, в личку писать только платежеспособным личностям
Пересчет двумерного массива в зависимости от внешних переменных
 
при полном файле формулы рушатся
По вопросам из тем форума, в личку писать только платежеспособным личностям
Пересчет двумерного массива в зависимости от внешних переменных
 
Цитата
bigfoot написал:
по началу денежного потока для каждой новой станции
сейчас, так понимаю, заполнено не правильно. ноль должен быть не в Р14, а в N14.
Цитата
bigfoot написал:
изменю стоимость открытия 1 станции с 5 на 1млн, то массив должен перестроиться с началом денежных потоков на более ранние месяцы
можно, наверное, предусмотреть, но это еще больше усложнит формулу и пересчет этой формулы
По вопросам из тем форума, в личку писать только платежеспособным личностям
Пересчет двумерного массива в зависимости от внешних переменных
 
.
По вопросам из тем форума, в личку писать только платежеспособным личностям
Выбор максимального значения за каждые сутки месяца.
 
Alex Alex, так по моему. массивная
Код
=ЕСЛИ((0=СУММ(ЕСЛИ(A$1:A1=A2;G$1:G1)))*(C2=МАКС(ЕСЛИ($A$2:$A$100=A2*ЕЧИСЛО($D$2:$D$100);$C$2:$C$100)));C2;"")
По вопросам из тем форума, в личку писать только платежеспособным личностям
Подсветить повторы в столбце по двум условиям
 
Цитата
hlm написал:
Нет это немного не то
а вот так то?
    А              В
1  Год     № документа
2  2018       и123
3  2019       и123
4  2019       и123
По вопросам из тем форума, в личку писать только платежеспособным личностям
Извлечь из диапазона числа больше 8 и просуммировать их по условию из другого диапазона
 
pantcevich, пропустил момент :)
Код
=СУММ(ЕСЛИ((A2:A11="а")*(0<ЕСЛИОШИБКА(--ПОДСТАВИТЬ(B2:B11;"к";"");0)-8);ЕСЛИОШИБКА(--ПОДСТАВИТЬ(B2:B11;"к";"");0)-8))
По вопросам из тем форума, в личку писать только платежеспособным личностям
Автоматическая расстановка мест в турнирной таблице, Прошу подсказать.
 
SLONik24, при таком раскладе все правильно?
По вопросам из тем форума, в личку писать только платежеспособным личностям
Подсветить повторы в столбце по двум условиям
 
hlm, вам как сделать? как здесь?
По вопросам из тем форума, в личку писать только платежеспособным личностям
Извлечь из диапазона числа больше 8 и просуммировать их по условию из другого диапазона
 
pantcevich, массивная. надеюсь, в тексте будет только буква "к"
Код
=СУММ(ЕСЛИ(A2:A11="а";ЕСЛИОШИБКА(--ПОДСТАВИТЬ(B2:B11;"к";"");0)))
По вопросам из тем форума, в личку писать только платежеспособным личностям
Автоматическая расстановка мест в турнирной таблице, Прошу подсказать.
 
Aleksey1107, и вам спасибо за формулу
можно и так использовать
Код
=ЕСЛИОШИБКА(РИМСКОЕ(ПОИСКПОЗ(СУММ(--(ЧАСТОТА((G41<G$41:G$52)*G$41:G$52;G$41:G$52)>0);0);{1;2;3};));"")
Изменено: artyrH - 19 Янв 2020 18:53:05
По вопросам из тем форума, в личку писать только платежеспособным личностям
Ищу наставника для введения в профессию аналитика данных, Наставничество в проекте по созданию сквозной аналитики
 
Timofey, это у Вас в продолжение первой темы?
По вопросам из тем форума, в личку писать только платежеспособным личностям
Автоматическая расстановка мест в турнирной таблице, Прошу подсказать.
 
:D
вот это работает?
Цитата
SLONik24 написал: если у победителей одинаковое количество очков, то призовых мест может быть несколько
По вопросам из тем форума, в личку писать только платежеспособным личностям
Автоматическая расстановка мест в турнирной таблице, Прошу подсказать.
 
Цитата
SLONik24 написал:
мне нравится
но эта формула не работает
По вопросам из тем форума, в личку писать только платежеспособным личностям
Автоматическая расстановка мест в турнирной таблице, Прошу подсказать.
 
SLONik24, Ctrl+Shift+Enter
По вопросам из тем форума, в личку писать только платежеспособным личностям
Автоматическая расстановка мест в турнирной таблице, Прошу подсказать.
 
SLONik24, в Н41 массивную
Код
=ЕСЛИОШИБКА(РИМСКОЕ(ПОИСКПОЗ(СУММ(($G$41:$G$52>G41)/СЧЁТЕСЛИ($G$41:$G$52;$G$41:$G$52))+1;{1;2;3};));"")
Изменено: artyrH - 19 Янв 2020 13:12:44
По вопросам из тем форума, в личку писать только платежеспособным личностям
Количество по частичному совпадению
 
Цитата
lihatskiyy написал:
не считает
да вы готовить не умеете. это же массивная формула :)  
По вопросам из тем форума, в личку писать только платежеспособным личностям
Парсинг вложенных таблиц по темам
 
Андрей VG, а getInfo куда дели? :)  
По вопросам из тем форума, в личку писать только платежеспособным личностям
Можно ли как-то использовать функцию ОКРУГЛ сразу для всех ячеек, которые уже заполнены разными формулами?
 
Slaff4ik3, смотреть надо
По вопросам из тем форума, в личку писать только платежеспособным личностям
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 68 След.
Наверх