Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Разделить название книги и автора
 
Спасибо Всем! Задача решена! :)
Разделить название книги и автора
 
Цитата
Гаубица написал:

Спасибо большое!
Разделить название книги и автора
 
Цитата
Казанский написал:
1. Заменить " / " на "/" (без кавычек)2. Данные - Текст по столбцам - с разделителями - другой:/
Спасибо большое. Познакомился с новой формулой :)
Разделить название книги и автора
 
Цитата
кузя1972 написал:
вариант функцииКод ? 12345Function bb(t$, Optional i& = 0) With CreateObject("VBScript.RegExp"): .Pattern = "[^/]+": .Global = True  If InStrRev(t, "/") Then bb = Trim(.Execute(t)(i)) Else bb = t End WithEnd Functionn
С позиции решение конкретно поставленной задачи - спасибо за решение. В следующий раз я точно не смогу сделать схожее :)
За файл с решением - огромное спасибо
Разделить название книги и автора
 
Цитата
Сергей написал:
автор в В2 и растянуть внизКод ? 1=ЕСЛИОШИБКА(ЛЕВСИМВ(A2;ПОИСК("/";A2)-1);"")название в С2  и растянуть внизКод ? 1=СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(A2;"/";ПОВТОР(" ";50));50))


Лень двигатель прогресса, доказано!!!
спасибо! Понял суть формул!
Разделить название книги и автора
 
Добрый день! Нужен хелп:
1. есть список купленных мною книг, который мне скинул интернет-магазин. Список представлен в формате  автор через слэш  название книги(или наоборот)
2. хочу удалить/скопировать только название книг и оставить в одной колонке, а автора - в другой.
3. я думал сделать следующим образом:
а) удалить все после слеша
б) удалить через ctrl-h слеш
с) таким образом останется только автор
д) повторить тоже самое, только до слеша
Вопрос: какая формула для а) и д)

Файл прикрепил

Спасибо
Вениамин
Проверка на соответствие диапозону
 
Цитата
Stics написал:
1=ИНДЕКС(D2:D23;ПОИСКПОЗ(E2;B2:B23;1))
Супер! Спасибо большое
Проверка на соответствие диапозону
 
Добрый день! Друзья, нужна помощь:
1. есть диапазон значений и коэффициентов, который используется для премирования.
2. если фактическое значение (выделено желтым) находится в диапазоне, то применяется соответствующий коэффициент для премирования из диапазона.
Прошу помочь с формулой
Спасибо
Вениамин  
Страницы: 1
Наверх