Страницы: 1
RSS
Отобразить список с данными по определенным критериям
 
 Здравствуйте, уважаемые знатоки, помогите, пожалуйста, решить задачку.

Имеется массив данных.
Необходимо отобразить только отфильтрованный по выбранным критериям список из этих данных.
Сложность в том (сложность для меня), что одним из критериев для списка является пересечение строк и столбцов этого массива.

Суть задачи проста, и, уверен, сразу всё станет понятно, при просмотре файла!

Моё почтение.
Изменено: Yeti_magic - 18.02.2019 16:09:28
 
Yeti_magic, а фамилии могут повторятся? или они уникальные?!
если да - МОГУТ ПОВТОРЯТСЯ то вот вариант из приемов https://www.planetaexcel.ru/techniques/2/81/
Изменено: Mershik - 18.02.2019 16:23:46
Не бойтесь совершенства. Вам его не достичь.
 
.
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$13;АГРЕГАТ(15;6;СТРОКА($A$1:$A$13)/(ИНДЕКС($A$1:$J$8;;АГРЕГАТ(15;6;СТОЛБЕЦ($A$1:$J$1)/($A$1:$J$1=$G$16)/($A$2:$J$2=$H$16);1))=$I$16);СТРОКА(A1)));"")
 
Прочитай эти статьи, возможно этот вариант тебе и нужен  https://www.planetaexcel.ru/techniques/2/77/
https://www.planetaexcel.ru/techniques/2/231/  
Изменено: amibus - 18.02.2019 18:49:30
 
amibus, на этом форуме с езнакомыми - на "Вы"
 
Всем спасибо, за помощь, сейчас буду пробовать варианты!
 
artyrH спасибо, всё работает как надо!
Страницы: 1
Читают тему (гостей: 1)
Наверх