Страницы: 1
RSS
Извлечь значения разделенные слэшем и суммировать по критериям
 
Здравствуйте,

На работе поставили задачу на основании критериев суммировать числа разделенные слэшем.
Есть список состоящий из соков и соуса.
Нужно из правого столбца разделенных слэшем чисел выделить вес отдельно для соков и соуса.
Прилагаю пример вместе с моими потугами.

Есть ли решение?
 
Нетто
Код
=СУММПРОИЗВ(--ЛЕВБ(H2:H7;ПОИСК("/";H2:H7)-1)*НЕ(ЕОШИБКА(ПОИСК("JUICE";A2:A7)>0)))

Брутто
Код
=СУММПРОИЗВ(--ПСТР(H2:H7;ПОИСК("/";H2:H7)+1;99)*НЕ(ЕОШИБКА(ПОИСК("JUICE";A2:A7)>0)))
 
"POMEGRANATE BERRY BOOST" - это  JUICE или SAUCE? По каким признакам из текста в первом столбце можно это узнать?
 
Цитата
_Igor_61 написал:
По каким признакам
Раз слова сок нет, значит не сок, а если не сок, то соус.  :)
 
Уверены, что в H9 у Вас верный результат?
А раздельно можно так
=SUM(IFERROR(VALUE(RIGHTB(SUBSTITUTE(H2:H8;"/";REPT(" ";9));9));)*SIGN(ISNUMBER(SEARCH(" juice ";" " & A2:A8 & " "))+ISNUMBER(SEARCH(" boost ";" " & A2:A8 & " "))))
или так
=SUM(IFERROR(VALUE(RIGHTB(SUBSTITUTE(H2:H8;"/";REPT(" ";9));9));)*SIGN(SUM(--ISNUMBER(SEARCH({" juice "" boost "};" " & A2:A8 & " ")))))
Краевые пробелы , только на случае если попадется в названии слово, но не определяющее тим продукта

Цитата
RAN написал:
Раз слова сок нет, значит не сок, а если не сок, то соус.
скисший сбреженный сок - тоже соус (Уксус)
Изменено: БМВ - 26.05.2019 14:08:13
По вопросам из тем форума, личку не читаю.
 
Цитата
БМВ написал:
скисший сбреженный сок - тоже соус
А не брага? )
 
_Igor_61,
Игорь, это тип сока, поэтому в моих неуклюжих попытках он также был указан в качестве критерия.

БМВ, Спасибо, приспособил под основной файл, работает отлично.
Цитата
БМВ написал:
Уверены, что в H9 у Вас верный результат?
Да, вроде все верно.

Всем откликнувшимся спасибо за помощь!
Страницы: 1
Читают тему (гостей: 1)
Наверх