Страницы: 1
RSS
Правило УФ для выделения ячеек суммарно превышающих определенное значение
 
Уважаемые форумчане, здравствуйте!
У меня есть таблица с расчетами зарплат сотрудников (ячейки B2:E2;I2:L2;S2:V2;AC2:AF2).
Задача, условным форматированием выделить ячейки которые суммарно из указанного диапазона составляют сумму превышающую 912000.
Попытался решить задачу следующим образом:
Правило: =СУММ($B2:$E2;$I2:$L2;$S2:$V2;$AC2:$AF2)>912000
Для диапазона: =$C$2:$E$116;$I$2:$L$116;$S$2:$V$116;$AC$2:$AF$116
и
Правило: Значение ячейки > 912000
Для диапазона: =$B$3:$B$4
Но при этих условиях выделяются все ячейки.
Таблица как есть и как должно быть во вложении.
Заранее спасибо!
Кросс
Изменено: Maximich - 23.01.2020 10:56:22
Кто ясно мыслит, тот ясно излагает.
 
Уважаемые форумчане, моя задача не решаема или я не понятно объяснил?
Кто ясно мыслит, тот ясно излагает.
 
Вы слишком притязательны. Если ответа на Ваш вопрос не поступило, значит проблема не нашла своего знатока, способного её решить. Будьте терпеливы.

Я постараюсь Вам помочь.
Создала правило УФ для маленькой таблицы внизу. Рядом формула со значением "ИСТИНА" - эта формула записана в Правило УФ
Код
=СУММ(ДВССЫЛ(АДРЕС(СТРОКА();4));ДВССЫЛ(АДРЕС(СТРОКА();5));ДВССЫЛ(АДРЕС(СТРОКА();6));ДВССЫЛ(АДРЕС(СТРОКА();7));ДВССЫЛ(АДРЕС(СТРОКА();8)))>912000
 
Maximich, проблема в том, что у Вас очень замороченная структура таблицы (промежуточные итоги между данных) и довольно суровые требования. Если заморочиться, то лично я  вроде бы могу нарисовать формулу, которая закрасит все значения, после того, как сумма перевалит за 912 тыс, а вот закрасить только первое из них-для меня уже фантастика.
Изменено: Wiss - 23.01.2020 13:38:47
Я не волшебник, я только учусь.
 
Цитата
Maximich написал:
моя задача не решаема
решаема, но не одним условием
 
Сделал всё-таки одной формулой:
=И(СУММ($B3:B3)-СУММПРОИЗВ($B3:B3;--НЕ(ЕОШ(НАЙТИ("за ";$B$2:B$2))))>912000;ЕОШ(НАЙТИ("за ";B$2));НЕ(СУММ(A3:$B3)-СУММПРОИЗВ(A3:$B3;--НЕ(ЕОШ(НАЙТИ("за ";A$2:$B$2))))>912000))
Я не волшебник, я только учусь.
 
Wiss, мне как раз и нужно закрасить все значения, после того, как сумма перевалит за 912 тыс. Это видно в строке 10 примера (Таблица "Как должно быть"), там красным помечены 10000 (столбец Т) и 1000 (столбец AE).

artyrH, Almera, спасибо!
Кто ясно мыслит, тот ясно излагает.
 
В УФ вот такую формулу
Код
=((B9<>"")*СУММЕСЛИМН($B9:B9;$B$8:B$8;"<>План*";$B$8:B$8;"<>Факт*";$B$8:B$8;"<>Регр*")*
       СЧЁТЕСЛИМН(B$8;"<>План*";B$8;"<>Факт*";B$8;"<>Регр*";B$8;"<>итог*"))>912000
Страницы: 1
Читают тему (гостей: 1)
Наверх