Страницы: 1
RSS
Поиск заданного набора символов в диапазоне
 
Добрый день!

Есть диапазон с текстовыми значениями вида (2-номердела/год) в рандомном порядке, иногда по несколько в ячейке:
1) 2-1234/2013; 2-12334/2014; 2-1245/2015; 2-56/2016; 2-78/2017; 2-7416/2018; 2-4/2019; 2-69/2020;
2) 2-234/13,  2-546/15, 2-3426/16, 2-365/17, 2-72/18, 2-347/19, 2-75/20
п.с. ";" и "," не относятся к содержанию ячейки, обозначают лишь, что это разные ячейки

Моя задача все /13, /14, /15, /16, /17, /18, /19, /20 заменить на /2013, /2014, /2015, /2016, /2017, /2018, /2019, /2020

До /20 все заменяю через поиск/замена "/13" на "/2013", "/14" на "/2014" и т.д.
Но с "/20" возникла проблема! Найти через поиск строго дело вида 2-1231/20 не выходит, подстановочные знаки типа "*/20" срабатывают не так как мне нужно. Через функции поиска пока тоже не получается. Через поиск по "не содержит" тоже, там можно только два условия задать.

Может кто сталкивался, прошу подсказать
Изменено: Дмитрий Плотников - 17.03.2020 12:02:24 (ошибка в задаче)
 
здравствуйте!
попробуйте не "/20", а "/20;" менять на "/2020;"
ну и с запятой аналогично
Изменено: Настя_Nastya - 16.03.2020 19:07:04
 
Здравствуйте! Уточню. ";" и "," не относятся к содержанию ячейки, я так обозначил в тесте, что это разные ячейки )
Изменено: Дмитрий Плотников - 17.03.2020 12:02:35
 
Цитата
Дмитрий Плотников написал:
не относятся к содержанию ячейки
так сделайте нормальный пример, чтобы не вводить никого в заблуждение
 
Цитата
Дмитрий Плотников написал:
я так обозначил в тесте, что это разные ячейки
"Уж сколько раз твердили мину..."
В примере (файле) нужно показывать, а не в сообщении описывать данные.
 
Прилагаю пример.
Изменено: Дмитрий Плотников - 17.03.2020 12:02:50
 
вариант формулой, но только для 2020 года
Изменено: venom51 - 17.03.2020 09:29:41
 
Дмитрий Плотников, в D3 и протянуть...
может можно и короче... и для 2-78/2013 (2-5/16) будет ошибка
Код
=ЕСЛИ(ДЛСТР(B3)-ПОИСК("/";B3;1)=2;ЛЕВСИМВ(B3;ПОИСК("/";B3;1))&"20"&ПРАВСИМВ(B3;ДЛСТР(B3)-ПОИСК("/";B3;1));B3)
Изменено: Mershik - 17.03.2020 09:44:42
Не бойтесь совершенства. Вам его не достичь.
 
Ребята, благодарю за помощь, не ожидал такого быстрого отклика, очень приятно :-)
Страницы: 1
Читают тему (гостей: 1)
Наверх