Страницы: 1
RSS
Формула для автоматического вывода данных из последней строки группы
 
Здравствуйте дорогие форумчане, помогите пожалуйста создать формулу, которая  в первой строке группы (в примере выделено желтым) автоматически будет выводиться данные из последней строки группы (выделено светло красным). Если в группе только одна строка, то выводиться ничего не должно. Спасибо огромное всем!  
Изменено: dom23 - 19.09.2020 09:46:09
 
dom23, прикольно)) вы бы еще штук 3434 листов добавли
Не бойтесь совершенства. Вам его не достичь.
 
Mershik, спасибо исправил )  
 
dom23, массивная формула
Код
=ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЕСЛИ(B6:ИНДЕКС(B6:B$32;ПОИСКПОЗ(ЛОЖЬ;ЕПУСТО($A6:$A$32);0)-1;1);"<>"&"")>0;ИНДЕКС(B6:B$32;ПОИСКПОЗ(ЛОЖЬ;ЕПУСТО($A6:$A$32);0)-2;1);"");ЕСЛИ(ЕПУСТО(ИНДЕКС(B6:B$32;СЧЁТЗ($B6:$B$32);1));"";ИНДЕКС(B6:B$32;СЧЁТЗ($B6:$B$32);1)))
Не бойтесь совершенства. Вам его не достичь.
 
Mershik, спасибо огромное, может есть возможность сделать ее непрерывной, что бы не вводить отдельно для каждой группы ?
 
Цитата
dom23 написал:
сделать ее непрерывной,
ничего не понял, если вы об ограничении диапазона - измените на нужный вам - но большой запас будет тормозит файл
$32 на нужную на нужную Вам строку...
Изменено: Mershik - 19.09.2020 14:20:19
Не бойтесь совершенства. Вам его не достичь.
 
Mershik,Что бы можно было вставить потянуть вниз, а не вводить для каждой группы отдельно.
 
Цитата
dom23 написал:
может есть возможность сделать ее непрерывной, что бы не вводить отдельно для каждой группы
для дат (столбец D):
=ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЕСЛИ(D6:ИНДЕКС(D6:D12;ПОИСКПОЗ(ЛОЖЬ;ЕПУСТО(A6:A12);0)-1;1);"<>"&"")>0;ИНДЕКС(D6:D12;ПОИСКПОЗ(ЛОЖЬ;ЕПУСТО(A6:A12);0)-2;1);"");ЕСЛИ(ЕПУСТО(ИНДЕКС(D6:D12;СЧЁТЗ(B6:B12);1));"";ИНДЕКС(D6:D12;СЧЁТЗ(B6:B12);1)))
для для "B" и "С" измените диапазоны аналогично
Цитата
dom23 написал:
Что бы можно было вставить потянуть вниз, а не вводить для каждой группы отдельно.
Протянуть вниз не получится, т.к. у вас в нижних ячейках используемые значения; только копирование формулы в верх каждой группы. Проверяемые диапазоны сместятся автоматически.
 
Михаил Витальевич С., не работает, выводит другую дату  
 
Там формулы массива, нужно ввести в первую ячейку и потом скопировать в верх каждой группы.
Страницы: 1
Читают тему (гостей: 1)
Наверх