Страницы: 1
RSS
Что быстрее, формула массива SUM/СУММ или SUMPRODUCT/СУММПРОИЗВ?
 
Поводом послужила тема
и предложенное там решение
=СУММПРОИЗВ(--(""&A1=""&'1'!A$2:A$112);'1'!B2:B112)
к нему претензий нет, но вспомнилось что не раз встречал упоминания о том, что  СУММПРОИЗВ быстра, и в частности использование разных аргументов быстрее. Решил проверить. сделал стенд из файла той темы на 100112 строк источника и 1000 строк расчета и вот результат

=SUMPRODUCT(--(""&A1=""&'1'!A$2:A$100112);'1'!$B$2:$B$100112)  -  11,60938
=SUMPRODUCT((""&A1=""&'1'!A$2:A$100112)*'1'!$B$2:$B$100112)   - 11,82031
что подтверждает выше сказанное
и
барабанная дробь
Скрытый текст
По вопросам из тем форума, личку не читаю.
 
А на стенд можно посмотреть?
Соблюдение правил форума не освобождает от модераторского произвола
 
buchlotnik, Михаил, он не предельно прост. Взял файл из темы по ссылке и размножил. Сюда не поместится, а писать несколько строк по генерации просто лениво.
По вопросам из тем форума, личку не читаю.
 
Если поискать, найдется тема (давняя, в закрытом старом форуме где-то), где было сравнение  двух функций. Были и тесты. В теме присутствовали KL (MVP), Serge_007, vikttur. Больше участников не помню...
По результатам обсуждения выяснили, что СУММПРОИЗВ с вариантом
--условие1;--условие;диапазон (без перемножения)
предпочтительнее и экономия времени достигалась до 30%.
 
vikttur, Ну то что быстрее и мой результат подтверждает, может не на столько, но можно допускать что с тех  пор 2016 стал оптимальнее считать, но меня больше результат массивной удивил.
прикольно другое, решил не то чтоб перепроверить а просто изменить структуру данных, все 100000 одинаковы и все подходят под одинаковое условие 1000 раз

20,96875
21,94531
22,44531
Изменено: БМВ - 17.11.2020 18:51:30
По вопросам из тем форума, личку не читаю.
 
Так в том-то и дело, что СУММ проигрывала в той теме

Цитата
БМВ написал: с тех  пор 2016 стал оптимальнее считать,
Да, кстати, такое может быть
 
Цитата
buchlotnik написал:
А на стенд можно посмотреть?
Скрытый текст


Скрытый текст


Как минимум, серьезных лидеров нет.
Изменено: БМВ - 17.11.2020 23:03:24
По вопросам из тем форума, личку не читаю.
 
Нашел подтверждение старым выводам
Скрытый текст
 
vikttur, только когда это было и подтвердить сейчас не получается.
По вопросам из тем форума, личку не читаю.
 
Добрый день, коллеги! В Excel 2019 64- соотношение примерно такое же, как у Михаила.
Владимир
 
sokol92, Владимир, спс. ну судя по всему оптимизировали. Конечно интересно посмотреть результаты при разных структурных данных, но разница не на столько велика чтоб делать ставку на тот или иной метод. Удобнее - чуть более длинный вариант. Его и можно пользовать, разве что не утверждать что это самое быстрое решение.
По вопросам из тем форума, личку не читаю.
Страницы: 1
Читают тему (гостей: 1)
Наверх