Страницы: 1
RSS
Почему при вычислении формул пустая ячейка больше нуля?
 
Есть ячейка А1 в которой есть условие что =ЕСЛИ(В1=0;"")
и есть ячейка А2 с формулой =ЕСЛИ(А1>0;10;"")
и почему то когда  В1=0, соответственно в А1="", то А2=10, хотя А1 пустая грубо говоря, а ее видит как >0
Как правильно прописать? и в чем может быть проблема?
 
=ЕСЛИ(А1>0;10;"")
Если А1 не больше 0, то в ячейке - текст нулевой длины. А любой текст > числа
Если значения ячеек используются в вычислеиях, правильно писать:
=ЕСЛИ(А1>0;10;0)
Или, если отрицательных значений нет, то простая ссылка:
=А1
 
Но нам нужно чтобы ячейки были без 0, то есть пустыми и чтобы через формулу. Через формат не вариант. Как тогда быть?
 
Цитата
dem.on87 написал:  пустыми и чтобы через формулу.
Никак.

Цитата
Через формат не вариант.
Если и макрос не вариант - то заготовьте карандаши и много бумаги...
 
Цитата
dem.on87 написал:
Как правильно прописать?
пропишите так, чтобы в результате вычислений над ВАШИМИ данными ВАША формула возвращала нужный ВАМ результат
если нужный результат не получается - значит что-то прописали не так! исправляйте пока не получите нужный результат
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Здравствуйте! Можно в формуле сравнивать не с 0, а с пустой ячейкой
 
Сергей Карамов, вопрос не в том, с чем сравнивать, а в том, что возвращает формула. А формула ВСЕГДА возвращает что-то, ячейка с формулой пустой не будет ни при каких условиях.
 
Сравнивать с ""
 
dem.on87, не запрещается иметь текстовые значения в диапазонах чисел, но последующие вычисления придется усложнять.
Если интересует решение самой задачи, создайте отдельную тему.
 
Элементарно просто... у вас путаница из за 2 возможных результатов в А1 - текст или логическое

=ЕСЛИ(длстр(A1)>0;10;"")
 
А я предлагал так =ЕСЛИ(A1<>"";10;"")
 
Цитата
dem.on87 написал:
то есть пустыми и чтобы через формулу
когда напишете ваш идеальный Excel* там сможете все организовать идеально
а в этом - нужно учиться пользоваться тем, что в него вложено разработчиками
Изменено: Ігор Гончаренко - 16.02.2021 16:34:19
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
dem.on87 написал:
Но нам нужно чтобы ячейки были без 0,
делаете проще: вычисления проводите с нулями, т.е. вместо "" именно "0". А затем в параметрах эксель указываете, чтобы ячейки с "0" отображались пустыми. Все.
 
Цитата
dem.on87 написал: Через формат не вариант.
Хотя, да, параметры - не совсем формат
 
Цитата
Сергей Карамов написал:
А я предлагал так =ЕСЛИ(A1<>"";10;"")
Спасибо всем. Пока подошел этот вариант, не знаю пока не будет ли как то это мешать дальнейшим рассчетам но пока работает.
Изменено: dem.on87 - 16.02.2021 15:36:28
 
Если у вас B1 будет равно 0 и в Формате Текст или внесете 10.2 (с точкой)... сработает неверно.
Приводите все сразу к одинаковым типам данных при сравнении. Иначе подводные камни в последствии...
Изменено: Marat Ta - 16.02.2021 18:21:30
 
Здравствуйте,Укажите пожалуйста 3-ий параметр в вашей формулe =ЕСЛИ(В1=0;"").
Скажите поточнее что вы именно хотите сделать.
 
Цитата
Esbi B написал:
Укажите пожалуйста 3-ий параметр в вашей формулe =ЕСЛИ(В1=0;"").
Третий аргумент необязательный. Что не так в формуле?
Вот горшок пустой, он предмет простой...
 
Цитата
dem.on87 написал:
=ЕСЛИ(А1>0;10;"")

Есть еще =Ч()., будет так: =ЕСЛИ(Ч(А1)>0;10;"")
Число оставит числом, а текст преобразует в 0. Думаю подходящий вариант с минимальным усложнением.  
Не перестаю удивляться возможностям excel и VBA.
 
Shama, в ячейке B1 = 0 - сработает, >0 уже нет, так как в A1 - Ложь, а это 0 возврат функции Ч()
Задача, не имеющая никакой практической ценности.... не тратьте на нее время )

Тема: Почему пустая ячейка больше 0 - Ответ: Потому что она не пустая.
 
Marat Ta, Да, как то не заметил про В=1. Ну в первом условии про это ни слова.
Как нам тогда в этом условии =ЕСЛИ(В1=0;"") получить больше нуля? Я конечно понимаю, что "">0 и ЛОЖЬ>0, но не думаю что именно так задумал автор) Можно уж было и по проще завуалировать условия :D  
Не перестаю удивляться возможностям excel и VBA.
 
Решения даны в сообщениях 10 и 11
Других решений больше нет при такой постановке задачи.
 
автор помер уже давно
а ответы все идут и идут
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
Marat Ta написал: Решения даны в сообщениях 10 и 11
По теме ответ дан в сообщении №2.
 
Я бы уточнил тему: "Почему при вычислении формул Excel ячейка, содержащая пустую строку, больше нуля?"

В Tele2 VBA другие правила...
Изменено: sokol92 - 17.02.2021 15:17:46
Владимир
 
Все, реклама пошла. Пора закрывать ветку, а то скоро интим услуги предлагать начнут.
Вот горшок пустой, он предмет простой...
Страницы: 1
Читают тему (гостей: 1)
Наверх