Страницы: 1
RSS
УФ значений попадающих в интервал чисел
 
Доброго времени суток. Нужна помощь. Требуется применить автоматическое закрашивание ячеек с числами в строе Е1-Х1, которые попадают в диапазон,  начальное значение которого в столбце А, а конечное в столбце В. Понимаю только как УФ применить по одной строке, но каждый день добавляется по от 2 до 5 новых строк и приходится в ручную закрашивать новые участки
 
В условное  форматирование нужно вписать формулу =И(E1>=$A1;E1<=$B1)
Я не волшебник, я только учусь.
 
Wiss, а если закрасить в одной строке как в примере?
 
Wiss,к сожалению, мне множить строку Е1-Х1 не надо, заполнять нужно именно в ней
 
оно?
Код
=СУММПРОИЗВ(--($B$6:$B$9>=E$1);--(E$1>=$A$6:$A$9))
 
Blood81,это гениально, спасибо!!!!!! а можно еще наложить такое же УФ если числа будут стоять в обратном порядке? то есть в столбце А окажется число больше чем в столбце В? Или придется делать отдельные ключевые столбцы в которых будут возвращаться значения в прямом порядке??
Изменено: squirrel2709 - 25.03.2021 08:26:08
 
в эксель вообще можно любое извращение впихнуть )))
например:
Код
=СУММПРОИЗВ(--((--($A6:$A10>$B6:$B10)*$A6:$A10)+(--($A6:$A10<$B6:$B10)*$B6:$B10)>=E$1);--(E$1>=(--($A6:$A10>$B6:$B10)*$B6:$B10)+(--($A6:$A10<$B6:$B10)*$A6:$A10)))

вот только скорость вычислений от этого страдает, да и вообще нужно ли?

в плане производительности и надежности всегда лучше сделать отдельный столбец где данные будут проверяться и выстраиваться в нужном порядке
 
Blood81, да, сделать отдельный столбец оказалось надежнее, тем более пришлось отсеивать еще пустые и текстовые ячейки, которые УФ не воспринимало и вообще ничего не отрисовывалось. Но вот возникла другая проблема, при переносе в гугл таблицы функция суммпроизв  УФ не вводится, пишет "неверная функция",при этом в экселе все работает как по маслу...(
 
=SUM(--(ABS($A$6:$A$10-E1)+ABS($B$6:$B$10-E1)=ABS($A$6:$A$10-$B$6:$B$10)))
По вопросам из тем форума, личку не читаю.
Страницы: 1
Читают тему (гостей: 1)
Наверх