Страницы: 1
RSS
Подсчёт количества при множественном условии
 
Всем привет!

Не могу взять в толк как посчитать количество совпадений по строке, но при условии что на пересечении строки и столбцов есть хотя бы одна заполненная (непустая) ячейка.
Для примера загрузил табличку с именами и фруктами.

Мне нужно посчитать у какого количества людей с именем "Вася" есть хотя бы одна заполненная ячейка на пересечении со столбцами "Яблоко", "Апельсин".  
 
=СУММПРОИЗВ(($A$3:$A$17="Вася")*($B$3:$C$17>0))
=СУММПРОИЗВ(($A$3:$A$17="Вася")*(($B$3:$B$17+$C$3:$C$17)>0))
Изменено: JayBhagavan - 01.07.2021 09:46:28

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Цитата
JayBhagavan написал:
=СУММПРОИЗВ(($A$3:$A$17="Вася")*($B$3:$C$17>0))
Формула отдаёт значение "3", хотя в примере только у двух Вась есть хотя бы одна заполненная ячейка.  
 
еще вариант
Код
=СУММПРОИЗВ((A3:A17=A3)*(B3:B17+C3:C17>0))
Лень двигатель прогресса, доказано!!!
 
Да, считает корректно, спасибо!
А можно ли проверять не на "значение больше 0" а на "ячейка не пустая"?  
Изменено: vikttur - 01.07.2021 09:56:22
 
Антон, исправил.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
@JayBhagavan @Сергей, спасибо, обе формулы отлично считают числовые значения!

А можно ли сделать так, чтобы они считали непустые ячейки? Т.к. в реальной задаче в ячейках может быть как текст, так и число или ссылка.  
 
Цитата
Антон написал:
А можно ли
Приложите пример более близкий к жизни
Лень двигатель прогресса, доказано!!!
 
=СУММПРОИЗВ(($A$3:$A$17="Вася")*(($B$3:$B$17<>"")+($C$3:$C$17<>"")>0))

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Сергей, более реальный пример.
Посчитать всех "Вася" у которых на пересечении с "Пол" или "Город" заполнена хотя бы одна ячейка.
Диапазон расширяется в реальном времени, каждую минуту добавляются новые строки
 
Код
=СУММ((A5:A34="Вася")*(B5:B34&C5:C34<>""))
 
Тимофеев, возвращает ошибку "Знач!", скриншот под спойлером.

Upd.: извините, сам дурак. Это формула массива была.
Сработало, большое спасибо!  
Изменено: Антон - 01.07.2021 10:50:00
Страницы: 1
Читают тему (гостей: 1)
Наверх