Страницы: 1
RSS
Нумерация строк по любому значению в соседнем столбце, Нумерация строк по любому значению в соседнем столбце
 
Всем добрый вечер!

Можно подсказать? Есть простейшая таблица. Как сделать так, чтобы при заполнении ячейки (любое значение) В2 в А2 присвоился номер 1, а далее при заполнении В3 в А3 был уже номер 2 и так далее?

Заранее спасибо!
Изменено: WhiteEagle14 - 09.07.2021 15:21:35
 
Цитата
WhiteEagle14 написал: Можно подсказать?
Конечно, можно. Подскажите, где файл-пример? :)
 
прикрепил)

Те в В2 пишем test_1 в А2 подтягивается 1.
в В3 пишем test_2 в А3 подтягивается 2.

Какая тут формула?)
 
1. Фомулой для А3 с протяжкой с запасом (если не критично наличие формул возвращающих пустоту, в А2 вручную единицу вставите)
Код
=ЕСЛИ(ЕПУСТО(B3);"";A2+1)
или для А2
Код
=ЕСЛИ(ЕПУСТО(B2);"";СТРОКА()-1)
2. Или переходим на "умные таблицы" и нумерация пойдет сама по заполнению любого столбца в строке
 
в кучку
Код
=ЕСЛИ(B2="";"";СЧЁТЗ($B$2:B2))
Лень двигатель прогресса, доказано!!!
 
Как понял:
=МАКС(ИНДЕКС(A:A;СТРОКА($1:$1)):ИНДЕКС(A:A;СТРОКА()-1))+1

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
3 листа = 3 решения (о которых выше писал)
Вариант с первого листа универсальней второго (допускает пустые по столбцу В)
Но третий имхо оптимальней первых двух - с умной таблицей (не будете привязаны к столбцу В, и без строк по А заполенных формулой возвращающей "")
Код
=СТРОКА()-СТРОКА(Таблица1[#Заголовки])
Изменено: andylu - 09.07.2021 15:49:25
 
andylu, Сергей, JayBhagavan - благодарю, все работает!)
 
Код
=ПОСЛЕД(СЧЁТЗ(B:B)-1)
Страницы: 1
Читают тему (гостей: 1)
Наверх