Страницы: 1
RSS
Развернуть таблицу из горизонтальной в вертикальную
 
Всем здравствуйте.

Прошу оказать помощи или подтолкнуть к правильной  формуле. Есть форма данных от руководителя, в которой даты указаны горизонтально, нужно получить точно такие-же данные, только чтобы дата была не горизонтально, а вертикально, и таким образом, чтоб было понятно руководителю, что согласно формулам или сводной таблице,  данные тянутся из формы (листа) данных от руководителя.
Формулой не получается, а сводной таблицей дата идёт как сумма значений, его это не устраивает.

Пожалуйста прошу помощи в формуле, или правильной сводной таблице, но только не макросы.
Файл примера во вложении
Изменено: vikttur - 15.07.2021 23:06:36
 
Здравствуйте. Формула для подтягивания даты
Код
=ИНДЕКС('Форма от руководителя'!$Q$2:$BS$2;ПОИСКПОЗ(P3;ИНДЕКС('Форма от руководителя'!$Q$3:$BS$130;СУММПРОИЗВ(('Форма от руководителя'!$F$3:$F$130='То, что должно получиться'!F3)*('Форма от руководителя'!$I$3:$I$130='То, что должно получиться'!I3)*('Форма от руководителя'!$E$3:$E$130='То, что должно получиться'!E3)*('Форма от руководителя'!$K$3:$K$130='То, что должно получиться'!K3)*('Форма от руководителя'!$N$3:$N$130='То, что должно получиться'!M3)*СТРОКА('Форма от руководителя'!$A$1:$A$128)););))
 
gling , Здравствуйте ). Хорошая формула, она может собирать данные с одного листа, а не с двух? C одного листа, по всем условиям, выдаёт ошибку, потому что рассчитана по столбцу "итого" второго листа, второй лист это образец, как должно получится, а не данные для формулы, можно переписать формулу если откинуть столбец "итого" и "дату" со второго листа?
Изменено: personwll - 18.07.2021 23:40:39
 
См. в сторону PLEX ->трансформация-> редизайн кросс-таблицы в плоскую...
 
Может на одном листе так надо?
Код
=ИНДЕКС(S3:AW3;ПОИСКПОЗ(МАКС(S3:AW3);S3:AW3;))
 
Смотрите приложение
Изменено: jakim - 17.07.2021 15:39:36
 
gling, в некоторых строчках по три и пять дат, а такой формулой выделяет одну и  самую первую.

jakim, огромное спасибо, это больше чем я хотела.  
 
Wlad, не совсем подходящая надстройка. Очень сложно потом вывести сводную таблицу в группировке дат, так как в данный столбец, сгруппируются дополнительные столбцы. Возможно не совсем разобралась, но признательна за идею, по факту может решить любые другие не менее важные задачи. Спасибо ).

Всем огромное спасибо за участие, вопрос снят, задача решена.
Изменено: vikttur - 18.07.2021 23:40:19
 
Может так?
Страницы: 1
Читают тему (гостей: 1)
Наверх