Страницы: 1
RSS
Суммировать значения столбца по критерию, который указывается в отдельной ячейке
 
Добрый день!
Подскажите, каким образом можно сделать, чтоб функция СУММЕСЛИ складывала ни только по 1 критерию. СУММЕСЛИМН не подходит.
Пример во вложении.
Требуется, посчитать сумму из столбца С по критериям со столбца В.
1 100
1  100
1  100
=300 и так далее. На данный момент я делаю руками...Т.е =СУММЕСЛИ(B:B;1;C:C) и меняю цифру 1,2,3 и так далее.
Вопрос,можно ли как-то автоматизировать?
Изменено: vikttur - 03.08.2021 17:59:48
 
А что мешает вместо ручного прописывания 1,2,3... сделать ссылку на ячейку с номером?
 
Измените
Код
=СУММЕСЛИ(B:B;6;C:C)
на
Код
=СУММЕСЛИ(B:B;B286;C:C)
 
Задача решена.
Спасибо!  
 
в Д1
Код
=ЕСЛИ(B2=B1;"";СУММЕСЛИ($B$1:B1;B1;$C$1:C1))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Формула
Код
=IF(B1=B2;"";SUMIF(B:B;B1;C:C))
 
Код
=--(B2<>B1)*СУММЕСЛИ($B$1:B1;B1;$C$1:C1)
Страницы: 1
Читают тему (гостей: 1)
Наверх