Страницы: 1
RSS
Ранг внутри условий
 
Добрый день!
Прошу помощи с формулой с столбце B, необходимо определить ранг внутри временного значения столбца C(внутри 1ой даты и 1 часа) ранг от 1 и максимально до 10, если одинаковых значений в столбце С больше 10, то 11 и последующие должны отображаться с рангом 99. Так же ранг должен считаться при условии, что столбец F не пустой.
Буду рад ваше помощи! :)
 
Это конечно не совсем ранг, но...
=IF(ISBLANK($F2);"";IFERROR(11-10^(LOG(11-(COUNTIFS(D:D;$D2;E:E;"<"&$E2;F:F;"<"&$F2)+COUNTIFS(D:D;$D2;E:E;$E2;F:F;"<"&$F2)+1)));99))
По вопросам из тем форума, личку не читаю.
 
Спасибо, но с 63 строки пошел сбой, не учитывает что дата уже поменялась. Так же по 71 строчке не учитывает что дата уже поменялась
 
так я вашу логику не менял :-)
=IF(ISBLANK($F2);"";IFERROR(11-10^(LOG(11-(COUNTIFS(D:D;$D2;E:E;$E2;F:F;"<="&$F2))));99))
правда с учетом вашей сортировки можно
=IF(ISBLANK($F2);"";IFERROR(11-10^(LOG(11-COUNTIFS(D$1:D2;$D2;E$1:E2;$E2;F$1:F2;"<>")));99)) и так как COUNTIFS по всему столбцу работает медленно, то второй вариант типа быстрее.
Изменено: БМВ - 01.09.2021 12:01:00
По вопросам из тем форума, личку не читаю.
 
Добрый день, подскажите как решить с ранжированием динамики :
ГруппаЗначениеБаллы
Иванов0.40%-1
Петров0.00%3
Лагуткин0.00%3
Носов-1.05%1
Уткин0.90%-2
Смирнов-3.76%2
 
Дмитрий нет, логика непонятна. Динамики в примере нет. И что Вы подразумеваете под "ранжирование динамики"?

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
В данном случае смысл следующий.... Имеется динамика по снижению потерь, если динамика отрицательная то значит потери снизились и это хорошо, если динамика положительная то это плохо (потерь стало больше относительно предшествующего периода). Если "0" то это значит, что человек потерь не допустил. Поэтому если 0% то это самый высокий балл, если значение со знаком минус это последующий балл в сторону снижения, если положительное значение, то значит - 1;-2 и т. Д.  
 
Дмитрий нет, а почему 0% - наивысшая оценка? Уменьшение затрат же лучше в случае, если затраты все-таки были, но не изменились.
Вы не «эффективный» менеджер ли случаем?
upd: отсутствие затрат вообще не должно быть 0%. Это -100%;)  
Изменено: surkenny - 12.10.2021 19:54:36
 
В части показателя "0"% тут подразумевается, что в прошлом году человек недопустил потерь, в этом году аналогично нет потерь.
Тут не имеется ввиду, что относительно прошлого периода нет динамики потому что человек ничего не делает. Этих я отсюда уже исключил.

Тут имеется под "0",что человек не допускает потерь вовсе.
Так что 0 это самые лучшие. Значения с отрицательным значением значит есть проблемы, но человек их решает.
 
Как понял. Формула МАССИВА:
=ЕСЛИ($B6=0;РАНГ($B6;$B$6:$B$11);ЕСЛИ($B6>0;-СУММ(--(ЧАСТОТА(ЕСЛИОШИБКА($B$6:$B$11/($B$6:$B$11>0)/($B$6:$B$11<=$B6);"");$B$6:$B$11)>0));СУММ(--(ЧАСТОТА(ЕСЛИОШИБКА($B$6:$B$11/($B$6:$B$11<0)/($B$6:$B$11>=$B6);"");$B$6:$B$11)>0))))

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Страницы: 1
Читают тему (гостей: 1)
Наверх