Страницы: 1
RSS
Обработать колонку чисел, заменив их 2 числами.
 
Всем доброе утро. Необходима помощь в формуле.

В колонке "A" перечислены цифровые значения от -3 до 3. Необходимо в колонке "B" оставить только значения -3 и 3, а все значения между ними (между каждым переходом от -3 к 3) меняются на соответствующее число выше (-3 или 3). На скриншоте показал цветом, как будет выглядеть колонка "B".

Пример:
Присвоим 2 числам имена-шаблоны: "3" = "3 число", "-3" = "-3 число".
В ячейке "А2" число "-3". Мы нашли первое  "-3 число". Далее смотрим остальные строки. Если в строке находится любое число от -2 до 2, то оно меняется на  "-3 число".  То есть с B3 по B19 ячейки будут заполнены цифрой "-3". Если значение =-3, то цифра не меняется.

Смотрим далее. Доходим до строки "A20". В ячейке "А20" число "3".
Если в строке находится число "3", то Мы нашли первое  "3 число". Cмотрим остальные строки. Если в строке находится любое число от -2 до 2, то оно меняется на  "3 число". То есть с B20 по B25 ячейки будут заполнены цифрой "3". Если значение =3, то цифра не меняется. И так далее обработка. То есть числа между -3 и 3 меняются на соответствующие им найденные имена-шаблоны ("3 число" и "-3 число").

Всем спасибо за помощь в решении!

 
Изменено: Юрий М - 04.09.2021 12:05:12
 
Код
=ЕСЛИ(ABS(A2)=3;A2;C1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Подскажите, как в данном случае потом присвоить значение из другой колонки ячейки для наших имен-шаблонов ("3 число" и "-3 число"). Чтобы данное значение также присваивалось к числам диапазона.

Пример:
А2 = E2 . соответственно все значения с А2 по A19 будут также =E2
А20 = E20 . соответственно все значения с А20 по A25 будут также =E20
На скриншоте показал - колонка F.

 
Изменено: oleg9911 - 04.09.2021 11:54:14
 
Цитата
oleg9911 написал:
Пример: А2 = E2
это где можно наблюдать такую картину? Ни в приложенном примере, ни на скринах у Вас ни в одной строке значение столбца А не равно значению столбца Е. Точнее есть соответствия, но уж точно не те, которые Вы показали. Соответствие начинается со строки 7(1 = 1), потом 8(2 = 2) и все в этом духе. Ни о каких 100 или 122 речи там быть не может, судя по примеру.
Изменено: Дмитрий(The_Prist) Щербаков - 04.09.2021 12:03:54
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Цитата
Дмитрий(The_Prist) Щербаков написал:
ни в одной строке значение столбца А не равно значению столбца Е.
Имеется ввиду не равны как числа, а равны присвоенные имена.
A2 = "-3 число" (1-ое)
A20 ="-3 число" (2-ое)
A26 = "-3 число" (2-ое) и тд

Cоотв если в колонке B  с А2 по A19 выводится цифра 3, а она равна "3 число"  то и в F надо вывести E2, т.к. по умолчанию E2 = A2,
E20=A20, E26=A26

Надеюсь, не запутал..
 
Цитата
oleg9911 написал:
Имеется ввиду не равны как числа, а равны присвоенные имена
очень хорошо. Еще бы кто-то кроме Вас тоже понимал о чем речь... Тогда может быть можно было бы решить. Подождем тех, кто понял. Я вот, например, вообще не понимаю, почему в А2 первое число, а в А26 - третье. А далее все еще запущеннее для меня
Цитата
oleg9911 написал:
если в колонке B  с А2 по A19 выводится цифра 3, а она равна "3 число"  то и в F надо вывести E2
эту логику я просто не осилил. Видимо, просто никак не соберусь с мыслями для Вашей задачи...
Изменено: Дмитрий(The_Prist) Щербаков - 04.09.2021 12:15:45
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Дмитрий(The_Prist) Щербаков, объясню по-другому.

Пример:
Проверяем колонку А. Выводим же в колонку D.
Смотрим колонку А. Если в колонке А число =-3 то в колонке D выводим число из колонки C. Это "1-ое найденное число -3".
Здесь получается, что в А3 число -3 , значит для D3 выводим значение из C3. Здесь это число "100"
Идем далее по каждой строчке. Если число снова =-3 то выводим в D также "1-ое найденное число -3" до тех пока пока не найдем в колонке А число =3.
Соответственно с D3 по D20 будет число "100"

Нашли в А21 нашли "1-ое найденное число 3". Соответственно в D21 выводим число из колонки C.  Здесь это число "122".
Идем далее по каждой строчке. Если число снова =3 то выводим в D также "1-ое найденное число 3" до тех пока пока не найдем в колонке А число =-3.
Соответственно с D21 по D26 будет число "122"

Другими словами надо заменить последовательность -3 / 3  из колонки "А"  - цифрами из колонки "С", сохраняя логику переноса, т.е. цифры между мы пропускаем, заменяя их. На скриншоте это наглядно показано.

 
Изменено: oleg9911 - 04.09.2021 12:36:01
 
Ох...каждый раз разные примеры...В предыдущих в столбце А другие данные, отсюда и недоразумения, как полагаю.
Формула для примера 2(из сообщения #3 от 04.09.2021 11:44:48):
Код
=ЕСЛИ(СУММ(B2;3)<>СУММ(B1;3);E2;F1)
для последнего пример, это будет скорее всего выглядеть так:
Код
=ЕСЛИ(СУММ(A2;3)<>СУММ(A1;3);C2;D1)
формулу начать вводить в ячейку D2.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Может так
=ЕСЛИ(A3<>A2;C3;E2)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Максим В. написал:
Может так
и то верно. Чё-то я слегка заморочился изначальным примером. Но если взять файл из самого первого сообщения, то можно сделать и без других столбцов - только А и F:
Код
=ЕСЛИ(И(ABS(A2)=3;A2<>A1);F2;F1)
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
Страницы: 1
Читают тему (гостей: 1)
Наверх