Страницы: 1
RSS
Определить, есть ли две точки в тексте, Формула
 
Здравствуйте. Помогите, пожалуйста, составить форуму, которая поможет найти в столбце строки с двумя точками (не двоеточие).
Код
слово.слово = одна точка
слово.слово = одна точка
слово.слово.слово = две точки (то что нужно)
слово.слово = одна точка
Быть может как-то через стандартный Фильтр можно сделать?
Изменено: vikttur - 17.09.2021 10:57:13
 
И Вам здравствовать. Почитайте Количество слов в ячейке
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Фильтр - Текстовые фильтры - Содержит - "*.*.*"
 
Код
=ПОИСК(".*.";A1)
вернет или #ЗНАЧ! или порядковый номер первой точки
фильтруем потом без #ЗНАЧ!,
или оборачиваем в =ЕСЛИОШИБКА(ЕСЛИ
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПОИСК(".*.";A2)>1;"есть 2 точки");"нет 2 точек")
или что и как для вашей конечной задачи дальше нужно
Изменено: andylu - 17.09.2021 10:49:42
 
=счетесли(Текст;"*.*.*")>0
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Спасибо люди добрые!
Страницы: 1
Читают тему (гостей: 1)
Наверх