Страницы: 1
RSS
Поиск корректного номера ШК по списку номеров
 
Добрый день! Помогите пожалуйста решить задачку! Необходимо чтобы в случае когда в ячейке B2 выводится фраза "Замена ШК", в ячейку C2 подтягивалось корректное значение из столбца A с листа "ШК", при этом столбец B листа "ШК" содержит в себе разные значения в том числе верное. Указал в С2 как должно быть. Заранее благодарю!
Изменено: vikttur - 22.09.2021 19:26:14
 
Добрый

Тема: Поиск корректного номера ШК по списку номеров

Проверяйте =IF(B2="Замена ШК";INDEX(ШК.$A$2:$A$26;SMALL(IF(ISNUMBER(FIND(A2;ШК.$B$2:$B$26));ROW($A$2:$A$26)-1;"");1));"")
массивная
будут ошибки, если есть номера, содержащие часть других номеров (например 123 и 456123)
ps

вариант покороче, но в excel  не проверял
=IF(B2="Замена ШК";INDEX(ШК.$A$2:$A$26;MATCH("*"&A2&"*";ШК.$B$2:$B$26));"")
Изменено: bigorq - 22.09.2021 15:14:44
 
Ещё вариант:
Код
=ЕСЛИ(B2="Замена ШК";ПРОСМОТР(;-ПОИСК(A2;ШК!B$2:B$26);ШК!A$2:A$26);B2)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
bigorq, Максим В., Спасибо огромное! Оба варианта рабочие! Только немного исправил на случай если таблица будет расти, указав столбики целиком: =ЕСЛИ(B2="Замена ШК";ПРОСМОТР(;-ПОИСК(A2;ШК!B:B);ШК!A:A);B2)
 
Цитата
Георгий Дзотцоев написал:
указав столбики целиком:
зря) лучше с запасом конкретные строки чем 1 млн.строк
Не бойтесь совершенства. Вам его не достичь.
Страницы: 1
Читают тему (гостей: 1)
Наверх