Страницы: 1
RSS
Как разделить и выбрать данные одной ячейки в другие ячейки
 
Здравствуйте, помогите пожалуйста выбрать числа с одной ячейки, которые отделены одна от другой пробелом и распределить эти числа в другие ячейки. И тоже самое только числа в одной ячейке отделены друг от друга дефисом. Спасибо
Изменено: irina2 - 23.09.2021 10:21:14
 
Инструмент "текст по столбцам" c выбором соответствующего разделителя. В примере с тире, в зависимости от региональных могут получится не числа, а текст, а если будет такое 1.4-2.5 то и вовсе даты , так что смотрите внимательно. я б сперва все текстом сделал, заменил десятичный разделитель после .
По вопросам из тем форума, личку не читаю.
 
irina2, Статья из приемов вам вполне поможет.
Либо просто используйте имеющийся инструмент - Данные - Текст по столбцам
 
1. Данные --- Текст по столбцам (разделитель-"пробел")
2. Данные --- Текст по столбцам (разделитель-"-")
 
 
Я так понимаю автоматом это не делается, через формулы. Только вручную.
Изменено: irina2 - 23.09.2021 09:48:21
 
Неправильно понимаете.  Но для того, чтобы написать формулу, нужно видеть, с чем ей работать. Вы показали только по одному варианту значений для разных условий. Других не будет? Например: другое количество символов между разделителями, тексты вместо числовых данных,  т.п.

Для показанных данных достаточно:
=--ЛЕВБ($C1;4)
=--ПСТР($C1;6;4)
=--ПРАВБ($C1;5)

Если извлекаются текстовые данные - убрать двойное отрицание. Если другое количество  символов - изменить числа в функциях
 
я б добавил еще просто количество значений, которое может получится в итоге  из одной , тоже нужно знать. вдруг их тысячи.
По вопросам из тем форума, личку не читаю.
 
Удалил второе условие, добавил ячейки (изменил эксель файл), так как какая то путаница получается ))
 
Пробуйте:
Код
=ЕСЛИОШИБКА(--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($A1;" ";ПОВТОР(" ";50));(СТОЛБЕЦ(A1)-1)*50+1;50));"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
irina2 написал: Удалил
irina - не Ирина? )

=ЕСЛИОШИБКА(--(ПСТР(ПОДСТАВИТЬ(" "&$A1;" ";ПОВТОР(" ";99));СТОЛБЕЦ(A1)*99;99));0)
Если нули мешают, их можно скрыть (галка по пути Файл-Параметры-Дополнительно-Для листа) или вместо нуля в конце формулы записать ""
"" - пустой текст, а наличие текста среди числовых данных может мешать дальнейшим вычислениям.
 
Извините, а куда этот код подставить?
 
irina2, в ячейку С1 и протянуть вправо и вниз
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Работает, но только на первую группу цифр.
Изменено: vikttur - 23.09.2021 11:26:17
 
На какую первую группу? А вариант viktturа?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Максим В. написал: протянуть вправо и вниз
Не только вниз, но и правее.
Не получается тянуть: копировать С1 с формулой, выделить диапазон, вставить
 
Ребята спасибо все получилось, всем большое спасибо.
Изменено: vikttur - 23.09.2021 11:34:45
Страницы: 1
Читают тему (гостей: 1)
Наверх