Страницы: 1
RSS
На сколько дней хватит остатка товара
 
Добрый день, такая задача, нужно рассчитать на сколько дней хватит остатка
что-то не получается у меня (
Изменено: vikttur - 12.10.2021 10:35:07
 
Не забыли из школьной программы, как делить одно число на другое?
 
Поиск.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
разделите остаток на расход в день  и обязательно сожгите аттестат о среднем образовании
Изменено: Ігор Гончаренко - 12.10.2021 10:41:59
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
Ігор Гончаренко написал:
обязательно сожгите аттестат о среднем образовании
Обязательно))) но все равно не получается ..(
я может не совсем правильно объяснил, вот чуть графически добавил, так надо чтоб посчитало в каждой ячейке для каждого дня .
 
Думаю, станет понятнее, если убрать слово Оборачиваемость из F6 )
Код
В ячейку F7        =ОБЕСПЕЧЕНО(D7;C7:C22)
Код
Function ОБЕСПЕЧЕНО(Остаток As Range, Заказы As Range) As Integer
    Dim d As Double
    Dim i As Long
    Dim cl As Range
    For Each cl In Заказы
        d = d + cl.Value
        If d > Остаток.Value Then Exit For
        i = i + 1
    Next
    ОБЕСПЕЧЕНО = i
End Function
Изменено: МатросНаЗебре - 12.10.2021 11:15:12
 
пока сами не определитесь как считать - никто вам не поможет((
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
МатросНаЗебре, спасибо!!!, то что надо!)
А формулой это вообще возможно
 
Цитата
Єдуард Марков написал: формулой это вообще возможно?
Гончаренко показал
Изменено: vikttur - 12.10.2021 16:13:14
 
Код
I1:X1             =СМЕЩ($B$6;СТОЛБЕЦ(A:A);0)
I2:X2             =ВПР(I1;$B:$D;3;0)
I3:X3             =СЧЁТЕСЛИМН(I7:I22;"<="&I2;I7:I22;">0")
I7:X22            =СУММЕСЛИМН($C$1:$C7;$B$1:$B7;">="&I$1)     
F7:F22            =ГПР(B7;$1:$3;3;0)        
Изменено: МатросНаЗебре - 12.10.2021 16:04:21
 
vikttur, да, показал, но та формула считает неправильно, ну или не так как надо, там красные цифры с правильными значениями, его решение не совпадает( ...

еще раз спасибо за участие! ) и терпение, я быстро разберусь)  
 
МатросНаЗебре, Спасибо! .. круто! ... в жизни бы не додумался до такого!! ( .... понимаю что не придется палить аттестат ... и дипломы! ))

учится и учится))
 
Цитата
Эд Мар написал: учится и учится
учитЬся и учитЬся
OFF

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
вот какой у нас форум - и по Excel подскажем и русский у ТС подтянем ))
 
Цитата
New: и по Excel подскажем и русский у ТС подтянем
и не только у ТСа))
Просто есть такие ошибки, которые суперлегко избегаются/проверяются (что делаеТ/ что делаТЬ) и при этом всё ещё сильно распространены - мне тоже глаз режет, хотя сам 1 из 100 раз точно ошибаюсь в спешке  :D
Во всех делах очень полезно периодически ставить знак вопроса к тому, что вы с давних пор считали не требующим доказательств (Бертран Рассел) ►Благодарности сюда◄
 
Цитата
JayBhagavan написал:учитЬся и учитЬся
Я не сомневался что гуру заметят :D , но не думал что не поймут почему я написал именно так! :cry:  :excl:  
Страницы: 1
Читают тему (гостей: 1)
Наверх