Страницы: 1
RSS
Можно ли формулой избавиться от экспоненциального числа
 
Здравствуйте подскажите, можно ли формулой по условию избавиться от экспоненциального числа, например если получилось вот такой "2,78E-08", то пишем "0,0000000278", а если нет то полученное число
 
формулой вы получите текст а не число, возможно вам нужен формат, но я с трудом понимаю что получилось и если нет ...
По вопросам из тем форума, личку не читаю.
 
Нет формат не подойдет.
 
Вы бы пример показали. Какие данные, какой результат
 
Вот пример
 
Код
=ФИКСИРОВАННЫЙ(D5;ДЛСТР(D5))
 
Тимофеев, ДЛСТР(D5)-2
Но результат все равно текст, не число...
 
число
 
Проверьте:
=ЕЧИСЛО(Ваша_формула)
Да и справка о функции об этом говорит:
Цитата
Округляет число до заданного количества десятичных цифр, форматирует число в десятичном формате с использованием запятой и разделителей тысяч и возвращает результат в виде текста.
 
верно.
тогда никак
Изменено: Тимофеев - 20.10.2021 13:44:12
 
Мне в принципи и так нормально, это конечный результат, как убрать последние два нуля?
 
vikttur, написал ДЛСТР(D5)-2
 
Цитата
Delux написал: и так нормально
Тогда нечего выдумывать:
=D5&""
 
Цитата
Delux написал:
формат не подойдет.
почему, если не секрет? Формат ячеек -Числовой. Выставляете знаки после запятой и все...Или смысл в том, чтобы лишние нули не отображались?
Изменено: Дмитрий(The_Prist) Щербаков - 20.10.2021 14:14:53
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Код
=ЗНАЧЕНИЕВТЕКСТ(D5)
 
Цитата
Тимофеев написал:
чтобы лишние нули не отображались
ДА
 
Цитата
vikttur написал:
Но результат все равно текст, не число...
Так ведь можно преобразовать
Код
=--ФИКСИРОВАННЫЙ(D5;ДЛСТР(D5)-2)
 :D
Изменено: Неопытный_Экселист - 20.10.2021 17:08:46
 
Цитата
Неопытный_Экселист написал:
Так ведь можно преобразовать
=--ФИКСИРОВАННЫЙ(D5;ДЛСТР(D5)-2)
ну да, решение огонь :) Пробовали, прежде чем советовать? Примените в приложенном файле предложенный вариант преобразования и посмотрите что в ячейке получится :) ровно то, что мешает использовать и просто числовой формат. При таком раскладе предложенная Вами формула не нужна, от слова совсем. Потому что мы изначально с числом работаем.
Изменено: Дмитрий(The_Prist) Щербаков - 20.10.2021 17:50:59
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
vikttur, Тимофеев спасибо за Вашу помощь
 
А как задать
Цитата
Delux написал:
можно ли формулой по условию избавиться от экспоненциального числа, например если получилось вот такой "2,78E-08", то пишем "0,0000000278", а если нет то полученное число
Как-то можно условием написать, что если экспоненциальное число, то это "=D5&""", а если нет то после запятой 6 знаков?
 
=ЕСЛИ(ЕЧИСЛО(ПОИСК("E";ТЕКСТ(D4;"@")));D4&"";ТЕКСТ(D4;"0,000000"))
 
Да, то что нужно, спасибо Вам огромное
Страницы: 1
Читают тему (гостей: 1)
Наверх