Страницы: 1
RSS
Суммирование значений в строке в нескольких столбцах по условию
 
Добрый день!
Подскажите пожалуйста, как применить суммесли, например если диапазон условия это a1:c1, условие "ааа", диапазон суммирования a2:c10. Получается нужно найти сумму всех значений в данном диапазоне по столбцам, но диапазон условий это строка. Вроде элементарная задача, а разобраться не могу.  
Изменено: vikttur - 14.11.2021 22:03:24
 
=СУММПРОИЗВ(...)
разбирайтесь
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Morphеus, Матрица, формула массива.
Код
=SUM(MMULT(N(A1:C1="aaa");--TRANSPOSE(A2:C10)))

Шучу, я шучу. Все гораздо проще))
Код
=SUMPRODUCT(A2:C10*(A1:C1="aaa"))
 
, , спасибо уважаемые форумчане, очень благодарен.  
Страницы: 1
Читают тему (гостей: 1)
Наверх