Страницы: 1
RSS
Разложение интервалов на временную шкалу по 5 минут, представить временной интевал на шкале
 
Здравствуйте подскажите пожалуйста как решить задачку
есть большое количество временных отрезков (начало; конец; нагрузка)
например
1 10:00-11:00 нагрузка 1, а нужно представить это на временной шкале по пятиминуткам, то есть в 10:00 - 1 в 10:05 - 1 и так далее по всем отрезкам

Пример приложил
Заранее благодарю
 
добрый день, в F2 и протянуть вниз и вправо
Код
=ЕСЛИ(И(ВРЕМЯ(ЧАС(F$1);МИНУТЫ(F$1);СЕКУНДЫ(F$1))>=$B2;$C2>ВРЕМЯ(ЧАС(F$1);МИНУТЫ(F$1);СЕКУНДЫ(F$1)));1;"")
Не бойтесь совершенства. Вам его не достичь.
 
Mershik,  я несколько иначе бы делал...
Код
=ЕСЛИ(И(F$1-ЦЕЛОЕ(F$1)>=$B2-0,00069;F$1-ЦЕЛОЕ(F$1)<=$C2+0,00069);1;"")


Не знаю почему, но если не накидывать минуту (0,00069) (может надо меньше) влево и вправо к диапазону, то не работает для всех диапазонов (т.е. .. >= и <= не всегда отрабатывают)
Изменено: tutochkin - 16.11.2021 13:04:08 (>= и <= не всегда отрабатывают)
 
Цитата
написал:
я несколько иначе бы делал...
не запрещено
Не бойтесь совершенства. Вам его не достичь.
 
Mershik, tutochkin огромное спасибо. Во втором примере дается лишняя единичка
 
Цитата
samox написал:
Во втором примере дается лишняя единичка
Всё зависит от граничных условий.
Впрочем у Вас теперь есть решение, и, я надеюсь, понимание куда копать.
Страницы: 1
Читают тему (гостей: 1)
Наверх