Страницы: 1
RSS
Сумма строк с ограничением диапазона по граничной сумме
 
Такой вопрос. Есть 2 столбика А, Б в столбике А написаны разные цифры(А1-50, А2-20,А3-30, и тд)в столбике Б пишем формулу. Формула должна считать: А1+А2+А3+... до тех пор пока не станет определённая сумма к примеру 100, после этого подсчёт должен идти заново (50+20+30=100., 60+30+20=100., 10(разница 110-100) +70+20=100 и тд. Надеюсь понятно объяснил какую формулу хочу узнать  
 
 
Цитата
Дмитрий Кулаков написал:
в деопозоне,
Всего три ошибки в слове ДИАПАЗОН. Но есть люди, которые в слове ещё умудряются сделать 4 ошибки.
 
в В1
=А1
в В2
Код
=ЕСЛИ(СУММ($A$1:A2)-100*СЧЁТЕСЛИ($B$1:B1;100)>100;100;ОСТАТ(СУММ($A$1:A2);100))
и тяните ее до конца деопозона в А)
Изменено: Ігор Гончаренко - 20.11.2021 09:54:15
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
, Спасибо что откликнулись на помощь, данная формула не работает так как мне нужно, сбросил файл, может поможет уловить мысль как я хочу.  
 
залаживайте Вносите
=IF(INT(SUM(A$2:A2)/100)-COUNT(C$1:C1);100;"")
и протягивайте.

Загадочная женщина, что угодно загадит... А если не успеет – придёт догадливая и догадит..
Изменено: БМВ - 20.11.2021 23:31:02
По вопросам из тем форума, личку не читаю.
 
Off
Загадочная женщина, что угодно загадит... А если не успеет – придёт догадливая и догадит..

Малыш хватит гадить :-) Куда сообщение подевал? Подстава. Пришлось наверх перенести.
Изменено: БМВ - 20.11.2021 23:32:34
По вопросам из тем форума, личку не читаю.
 
Да спасибо работает, но я не сказал про промежуточный итог, он не должен входить в формулу.
 
Цитата
Дмитрий Кулаков написал:
но я не сказал про промежуточный итог
вскрываем прикуп!!! Что еще осталось нескAзанным???

=IF(INT(SUMIF(A$2:A2;"<>ИТОГО:";B$2:B2)/350000)-COUNT(C$1:C1);350000;"")
Изменено: БМВ - 21.11.2021 08:13:12
По вопросам из тем форума, личку не читаю.
 
Цитата
написал:
но я не сказал про промежуточный итог
много еще у вас козырей в рукавах
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
а если будет 2 итога, или как в формулу можно вставить ограничения по 2 словам?
 
Можно ещё так:
Код
=ОКРВНИЗ(СУММЕСЛИ(A$2:A2;"<>итого:";B$2:B2)-СУММ(C$1:C1);350000)
но "0" придётся скрыть форматом.
 
в прикупе осталась еще одна карта неоткрытая  :D
=IF(INT(SUMIF(A$2:A2;"<>И*";B$2:B2)/350000)-COUNT(C$1:C1);350000;"")
По вопросам из тем форума, личку не читаю.
Страницы: 1
Читают тему (гостей: 1)
Наверх