Страницы: 1
RSS
Количество подряд идущих одинаковых значений в строке
 
Помогите, пожалуйста.
Нужна формула, которая подсчитывала бы количество одинаковых подряд идущих значений в строке справа налево.
Т.е. берется значение из крайнего правого столбца, сравнивается с предыдущим, если они равны, по кол-во равно - 2 (если не равны, то ноль и далее уже ничего не проверяется). Если последний и предпоследний столбцы равны, сравниваем предпоследний с соседним левым, если равно, то кол-во будет 3 и т.д. В примере уже подсчитано количество. Формула должна выдавать эти значения
Изменено: Ankras - 22.11.2021 13:05:07
 
А по какому принципу в третьей строке у вас 6, а в 9й - 9? Ошибка или тайный принцип?
Изменено: Xel - 22.11.2021 13:10:55
 
Исправил уже этот косяк, извиняюсь, файл уже другой загружен. 5 и 10, конечно
 
Так?
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:J2;J2)=1;0;СЧЁТЕСЛИ(A2:J2;J2))
 
Msi2102, в 13й строке ошибается.
 
Да, в 13-ой ошибка
 
Формула массива:
Код
=ЕСЛИ(J2<>I2;0;11-ПОИСКПОЗ(1=1;A2:J2=J2;))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Ну может тогда так?
Код
=ЕСЛИ(ИЛИ(СЧЁТЕСЛИ(A2:J2;J2)=1;J2<>I2);0;СЧЁТЕСЛИ(A2:J2;J2))
 
Там где 0 все ОК, а других выдает #знач!
 
MSI2102 - да, работает! Спасибо! А правила форума позволяют еще как-то отблагодарить кроме спасибо?
 
Цитата
Ankras написал:
как-то отблагодарить кроме спасибо
"Спасибо" хватит с лихвой, для другой благодарности есть раздел "Работа"
 
Чувствую себя халявщиком. Еще раз большущее спасибо за помощь! Плюс Вам в карму!
 
=(10-IFERROR(LOOKUP(2;1/(A2:J2<>J2);COLUMN(A2:J2));))*(J2=I2)

Цитата
Ankras написал:
MSI2102 - да, работает! Спасибо!
ровно до тех пора когда не будет такая комбинация
1,1,2,2,1,1,2,2,1,1
тогда покажет 6 а вроде нужно 2
Изменено: БМВ - 22.11.2021 13:42:44
По вопросам из тем форума, личку не читаю.
 
Цитата
БМВ написал:
тогда покажет 6 а вроде нужно 2
Так я так и понял, если соседние столбцы равны, иными словами J=I, то считаем все совпадения
Изменено: Msi2102 - 22.11.2021 13:53:10
 
Msi2102,
Цитата
Ankras написал:
количество одинаковых подряд идущих значений в строке справа налево
По вопросам из тем форума, личку не читаю.
 
1,1,2,2,1,1,2,2,1,1 При такой комбинации должно быть значение 2 (две последних единички только считаем)
 
Ankras, Тогда переадресовывайте СПАСИБО БМВ,  :D
Страницы: 1
Читают тему (гостей: 1)
Наверх