Страницы: 1
RSS
Как взять фрагменты текста в скобки
 
Приветствую ребята, подскажите пожалуйста, есть номер 0104660004730929210000066051743, как можно тут определенную часть взять в скобочки, например  (01)04660004730929(21)0000066051743
Изменено: vikttur - 27.11.2021 13:34:53
 
составьте новое значение из исходного и скобочек
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
fortochkin05,  определить как определить эту определенную часть и по этому правилу поставить скобки.
По вопросам из тем форума, личку не читаю.
 
fortochkin05,  уточните задачу. Например,  как определять нужную комбинацию цифр? Что делать, если такая комбинация встречается несколько раз?
 
Комбинация как в примере, меняться не будет
 
Т.е. нужно конкретно 01 и 21? Или нужно брать в скобки конкретные позиции в строке?
Порчему из Вас нужно тянуть клещами условия?
 
Юрий, надо брать в скобки (01) и (21) (то-есть после (01) надо пропустить 14 цифр и после 14-ти 2 цифры взять в скобки)

в файле посмотри пожалуйста)
 
Код
="("&ПСТР(A1;1;2)&")"&ПСТР(A1;3;14)&"("&ПСТР(A1;17;2)&")"&ПСТР(A1;19;13)
 
Тимофей) тииигр) спасибо тебе большое)
 
="("&REPLACE(REPLACE(REPLACE(A1;19;;")");17;;"(");3;;")")
По вопросам из тем форума, личку не читаю.
 
Цитата
fortochkin05 написал:
Юрий, надо брать в скобки (01) и (21
Вы так и не поняли, что плохо описываете задачу:
1. Нужно взять в скобки  конкретно комбинации 01, каком бы месте строки она не находилась.
2. Нужно взять в скобки первые два символа.
Есть разница в постановке задачи?
 
Код
=ЛЕВСИМВ(ПОДСТАВИТЬ(A1;"01";"(01)");18)&ПОДСТАВИТЬ(ПРАВСИМВ(A1;15);"21";"(21)")
 
Код
=ТЕКСТ(ЛЕВБ(A1;16);"(00)00000000000000")&ТЕКСТ(ПРАВБ(A1;15);"(00)0000000000000")
 
Цитата
Тимофеев написал:
=ТЕКСТ(ЛЕВБ(A1;16);"(00)00000000000000")
а если первым будет не 0???
По вопросам из тем форума, личку не читаю.
 
тогда беда
Если первый не 0:
Код
=ТЕКСТ(ЛЕВБ(A1;15);"(##)0000000000000")&ТЕКСТ(ПСТР(ПРАВБ(A1;16);1;15);"0(00)000000000000")&ПРАВБ(A1;ДЛСТР(A1)-30)
Изменено: Тимофеев - 27.11.2021 15:51:47
Страницы: 1
Читают тему (гостей: 1)
Наверх