Страницы: 1
RSS
Автоматическое объединение двух дат в соответствующую им рабочую неделю
 
Дорогие программисты, всем привет!
Всех с наступающим Новым годом, добра и реализации поставленных задач!

Задача как раз возникла из-за Нового года. Нужно адаптировать отчетность к следующему году. Практически во всех отчетах есть листы "данные" (которые содержат определенные справочники для упрощения жизни) на которые мы ссылаемся нашими формулами.
Во вложении пример  файла, где в ячейке B2 нужно прописать формулу, которая склеивала бы из столбца А даты понедельника и пятницы текущей рабочей недели в формат дд.мм.-дд.мм.гггг., а начиная с ячейки b7 в строке должно уже быть 17.01-22.01.22 (что соответствует второй рабочей недели) и т.д.
Помогите пожалуйста автоматизировать этот момент!
 
"в лоб":
в B2:
=ЕСЛИ(ДЕНЬНЕД(A2;11)=1;ТЕКСТ(A2;"ДД.ММ.-")&ТЕКСТ(A2+4;"ДД.ММ.ГГГГ");B1)
и протягиваете вниз
Изменено: Бахтиёр - 15.12.2021 16:19:30
 
Код
=ТЕКСТ(A2-ДЕНЬНЕД(A2;2)+1;"ДД.ММ.")&"-"&ТЕКСТ(A2-ДЕНЬНЕД(A2;2)+5;"ДД.ММ.ГГГГ")
Код
=ПРАВСИМВ("0"&ДЕНЬ(A2-ДЕНЬНЕД(A2;2)+1);2)&"."&ПРАВСИМВ("0"&МЕСЯЦ(A2-ДЕНЬНЕД(A2;2)+1);2)&".-"&ПРАВСИМВ("0"&ДЕНЬ(A2-ДЕНЬНЕД(A2;2)+5);2)&"."&ПРАВСИМВ("0"&МЕСЯЦ(A2-ДЕНЬНЕД(A2;2)+5);2)&"."&ГОД(A2-ДЕНЬНЕД(A2;2)+5)
Изменено: МатросНаЗебре - 15.12.2021 16:22:14
 
Не совсем, выдает 0 со вторника по пятницу
 
я исправил, посмотрите
 
Спасибо огромное, гениально!
а то мучался с этими форматами для дат!
Страницы: 1
Читают тему (гостей: 1)
Наверх