Страницы: 1
RSS
Получить даты за период
 
Нужно проставить даты периодов, составил формулу, ошибка в периоде «2» - вылазят не те даты, хочу с 15 по последний день месяца.

Подскажите пожалуйста как исправить.
Буду рад, если покажите формулу изящнее моей;)
Код
=ЕСЛИ(C2=1;СЦЕПИТЬ("с ";ТЕКСТ(ДАТА(2022;B2;1);"ДД.ММ.ГГГГ");" г. по ";ТЕКСТ(ДАТА(2022;B2;15);"ДД.ММ.ГГГГ");" г. ");
СЦЕПИТЬ("с ";ТЕКСТ(ДАТА(2022;B2;16);"ДД.ММ.ГГГГ");" г. по ";
ТЕКСТ(ДАТА(2022;B2;КОНМЕСЯЦА(ДАТА(2022;B2;1);0));"ДД.ММ.ГГГГ");" г. ";))
 
И вам здравствовать!
Код
=ЕСЛИ(C2=1;"с "&ТЕКСТ(B2;"ДД.ММ.ГГГГ ""г. по """)&ТЕКСТ(B2+14;"ДД.ММ.ГГГГ ""г.""");"с "&ТЕКСТ(B2+15;"ДД.ММ.ГГГГ ""г. по """)&ТЕКСТ(КОНМЕСЯЦА(B2;0);"ДД.ММ.ГГГГ ""г."""))
 
Супер, вы не только исправили, но и сократили формулу на половину (на 106 символов).
Спасибо большое, и вам здравствовать!

Подскажите пожалуйста, как у вас считался на 2022 год? У меня за 1900 выходит(
 
Обратите внимание на ячейки столбца В. Там не цифры порядкового номера месяца, а даты, формат ячеек "М".
Страницы: 1
Читают тему (гостей: 1)
Наверх