Страницы: 1
RSS
По двум критериям (квоте и по факту) найти нужный балл
 
Добрый день!
Помогите составить формулу для решения такой задачи: есть матрица - по строкам в В5:В19 находится КВОТА минут, в значениях С5:Q19 ФАКТ минут. Нужно зная квоту и факт узнать из строки 4 - какой балл заработал работник. Я так думаю, что здесь нужны формулы ИНДЕКС, ПОИСКПОЗ, СМЕЩ, может ещё какая - но не могу их собрать до кучи чтобы работало.
 
Код
=ИНДЕКС(C4:Q4;ПОИСКПОЗ(I29;СМЕЩ($B$4;ПОИСКПОЗ($I$28;$B$5:$B$19;0);0;1;1+1*СЧЁТ($B$4:$Q$4));-1))
 
Спасибо, работает. А что делает функция СЧЕТ в конце формулы? Хочу понять логику.
 
Цитата
написал:
функция СЧЕТ в конце формулы
Определяет количество столбцов в строке, в которой идёт поиск.
 
Спасибо большое. Вроде бы разобрался.
 
почему -3  по тому что ближе к 120 или .....?
По вопросам из тем форума, личку не читаю.
 
Да, совершенно верно. Если число не дотягивает, то балл берётся от меньшего
 
=INDEX(B4:Q4;MATCH(I29+"0:0:1";INDEX(B5:Q19;MATCH(I28+"0:0:1";B5:B19;-1););-1))
Изменено: БМВ - 17.01.2022 13:58:55
По вопросам из тем форума, личку не читаю.
 
Интересная формула - почти работает. Показывает ошибки если квота 280 и факт 280. А факт может быть и больше квоты (в таком случае всё-равно оставляем 1 балл). Но это условие я сам смогу прописать.
 
если квота всегда равна табличному значению то чуть проще. не надо прибавлять секунду, ну и в идеале лучше прибавлять пол секунды, то есть еще поделить на 2
По вопросам из тем форума, личку не читаю.
 
Всем спасибо за помощь. Задача решена.
Страницы: 1
Читают тему (гостей: 1)
Наверх