Страницы: 1
RSS
Почему формула не воспринимает значения из заголовка умной таблицы?
 
Почему первая формула считает верно



а вторая - нет ?

Изменено: Partizano _pl - 20.01.2022 15:54:29
 
Добрый день. А сам фаил можно прикрепить? На картинках всё ок. Возможно в свойствах ячейки  проблема.
 
потому что заголовки возвращают текст и с числом сравнить нельзя
Код
массив попробуйте: =Продажи10[[#Заголовки];[1]:[12]]
Изменено: Тимофеев - 20.01.2022 16:25:52
 
Цитата
написал:
Добрый день. А сам фаил можно прикрепить? На картинках всё ок. Возможно в свойствах ячейки  проблема.
Прикрепил
 
Попробуйте так
Код
=СУММПРОИЗВ((ЧЗНАЧ(B3:M3)<=4)*B4:M4)
 
Вы хотите сказать, что в умной таблице формат ячеек в шапке - ВСЕГДА только текстовый?
 
Получается что да
 
Цитата
написал:
в умной таблице формат ячеек в шапке - ВСЕГДА только текстовый?
именно так. Проверить легко - установите любой числовой формат(да хотя бы дата) для всего столбца, включая заголовок. Потом вбейте дату вида "янв.22" в заголовок и в ячейку ниже и посмотрите, что в итоге будет в заголовке, а что в ячейке таблицы. В заголовке будет текст, а в ячейке - дата в формате даты-времени Excel.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Понятно. Хреновая новость.

Спасибо всем!
Страницы: 1
Читают тему (гостей: 1)
Наверх