Страницы: 1
RSS
Сумма диапазона по условию в строках
 
Прошу подсказку.
В желтом диапазоне нужно просуммировать значения, но только те из них, которые находятся в строках со значением "Учетный".
Код
=СУММЕСЛИ(A3:A5;"="&"Учетный";B3:G5)
- не катит
 
Код
=СУММ((A3:A5=A5)*B3:G5)
Изменено: Тимофеев - 25.01.2022 10:26:11
 
Как в #2 у меня не получилось. Выдаёт ошибку. Мой вариант не бесспорный но считает :)
 
Я как раз этого и хотел избежать )) Но спасибо за попытку! )
№2 все же - лучшее решение.

Благодарю!
 
Код
=СУММ(ИНДЕКС($B$3:$G$5;ПОИСКПОЗ("Учетный";$A$3:$A$5;0);))
 
Благодарю!
 
Цитата
Basil S. написал: Как в #2 у меня не получилось.
Формула массива вводится тремя клавишами. А чтобы не искать три клавиши:
=СУММПРОИЗВ((A3:A5=A5)*B3:G5)

Цитата
...которые находятся в строках со значением "Учетный".
Rickoshet, а их может быть больше одной. А если одна - зачем ее искать? )
 
Согласен, у меня на схожей структуре данных были ограничения по датам, а вместо "учетный" были статьи затрат. Без этих условий, мое решение совсем не к месту.

формула из #2 требует массивного ввода? У меня на 365 считает так.
 
В 365 и 21 не нужен массивный ввод
 
Тимофеев, понял, спасибо!
Изменено: Rickoshet - 25.01.2022 11:32:17
 
Vikttur, я уже разобрался что там массивный ввод комбинацией из трёх пальцев :)
Страницы: 1
Читают тему (гостей: 1)
Наверх