Страницы: 1
RSS
В зависимости от выбора в списке подставлять значения из одной из трех таблиц
 
Буду признателен за подсказку!

Есть желтый диапазон. В зависимости от выбора в списке справа в него должны подставляться значения из одной из трех таблиц ниже.
 
если в лоб
 
Код
=ЕСЛИ(M2=A12;B12:K18;ЕСЛИ(M2=A20;B20:K26;ЕСЛИ(M2=A28;B28:K34;"")))
Изменено: Тимофеев - 25.01.2022 15:38:16
 
Для В3:
=ВЫБОР(ПРАВБ($M$2);B12;B20;B28)
=ИНДЕКС((B12;B20;B28);;;ПРАВБ($M$2))

Копировать на всю таблицу
 
Цитата
=ЕСЛИ(M2=A12;B12:K18;ЕСЛИ(M2=A20;B20:K26;ЕСЛИ(M2=A28;B28:K34;"")))
Подскажите, а как вводить эту формулу? В примере она работает, а в моей таблице выдает ошибку ПЕРЕНОС.....

P.S. Разобрался. С умной таблицей эта формула не прокатывала. Пришлось сделать глупой )
ВСЕМ СПАСИБО!
Страницы: 1
Читают тему (гостей: 1)
Наверх