Страницы: 1
RSS
Суммирование по нескольким критериям, Подстановка результата суммирования на основе нескольких критериев
 
В столбце "D" нужна формула которая посчитает разницу между тем что было на складах и тем что вывезли
На "Склад 1" было 10 едениц "зеленый", вывезли 4 еденицы "Карандаши зеленые" - осталось 6 едениц
"зеленый", затем со "Склад 1" вывезли 5 едениц "ручки зеленые" - осталась 1 еденица "зеленый", при попытке вывезти со "Склад 1" еще 2 "ручки зеленые" ячейка "D12" выделяется красным и показывает отрицательный результат "-1".
Разницу между тем что было и тем что вывезли необходимо считать только на "Складах", в ячейках которые напротив "Хранилище" в идеале должна остаться пустая ячейка, если будет высвечиваться ошибка - не страшно.
Решение с помощью макросов не желательно, строк очень много - поэтому формулы массива так  же не приветствуются.
Можно добавлять вспомогательные столбцы или строки, ну или перенести расчеты на отдельный лист и притягивать (подставлять) результат вычислений в зависимости от того какие значения вносятся в столбцы "А", "В" и "С".
 
Коряво. Но работает.
 
Формула массива. Проверяйте, ваш результат не сходится с тем что выдала формула.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$18:$D$22;ПОИСКПОЗ($A2;$A$18:$A$22;);ПОИСКПОЗ(1;--(НАЙТИ($B$17:$D$17;$B2)>0);))-СУММЕСЛИМН($C$2:C2;$A$2:A2;A2;$B$2:B2;B2);"")
Страницы: 1
Читают тему (гостей: 1)
Наверх