Страницы: 1
RSS
скопировать или перенести ячейки при выполнении нескольких условий
 
Добрый вечер. Есть очень корявый файл. Нужно при условии отрицательного значения в ячейке, просмотреть подчинённые ячейки и если в них условие выполняется то скопировать или перенести данные на другой лист Очень тяжело описать словами задачу.
Максимально попыталась объяснить в прикреплённом файле.
Фильтр для решения задачи не удобен
Может кто-то подскажет с помощью какой Функции удобнее сделать
 
Попробовала с помощью ЕСЛИ
=ЕСЛИ(ИП!E2<0;ЕСЛИ(ИП!F3>=ИП!E2*-1;ИП!B3;"");"")
=ЕСЛИ(A2=ИП!B3;ИП!E2*-1;"")
но первая функция просматривает только первую строку после отрицательного значения
А вторая вообще как-то выборочно оставляет ячейки или пустыми или с 0 (пока не поняла почему)
Но какоё-то результат есть, хоть и с большим количеством действий, и не полными данными))) в общем успокаиваю себя как могу)

Если подскажете в какую сторону смотреть буду очень благодарна.
 
Могу только макросом помочь.
Скрытый текст
Изменено: doober - 28.02.2022 23:48:45
 
Изменила данные в файле. При активации макроса он начал подтягивать данные после пустой ячейки.  Подскажите, я что-то сделала не так?
 
Это я не учел.
 
Спасибо огромное. Вы меня уже не первый раз спасаете. Всё работает
Страницы: 1
Читают тему (гостей: 1)
Наверх