Страницы: 1
RSS
Выборочные вычисления по нескольким критериям, Выборочные вычисления по нескольким критериям
 
Здравствуйте.
С помощью функции "СУММЕСЛИМН" ищу Сумму всех заказов (столбец "В") по условию 1 "Посредник" (столбец "С") и при условии 2 и 3 (столбец "А") в диапазоне дат (начальная и финишная дата указываются в ячейках F2 и F3 соответственно).
Код
=СУММЕСЛИМН(B2:B87;C2:C87;"Посредник";A2:A87;"<="&F2;A2:A87;">="&F3)
В результате "ноль". В чем может быть ошибка?
Спасибо.
 
Ошибка в том, что у вас в столбце А нет дат. Там текст, выглядящей как дата.
 
RAN, Спасибо, исправил.
Изменено: comment.imho - 03.04.2022 13:11:30
 
Смотрите, и ошибка в формуле.
Код
=SUMIFS(B2:B87;C2:C87;F7;A2:A87;">="&F2;A2:A87;"<="&F3)
Изменено: jakim - 03.04.2022 09:11:29
 
jakim, Спасибо, такая глупая ошибка с моей стороны.
Результат
Код
=СУММЕСЛИМН(B2:B87;C2:C87;"Посредник";A2:A87;">="&F2;A2:A87;"<="&F3)
Изменено: comment.imho - 03.04.2022 09:18:34
Страницы: 1
Читают тему (гостей: 1)
Наверх