Страницы: 1
RSS
Сумма значений с условием в строке, в одной ячейке.
 
Здравствуйте.
Не "пинайте" меня, я только учусь работать с формулами. Есть таблица с данными парковки (прилагается). Нужна формула, где 1-260, 2-500, а 3-650 и суммировать значения (260,500,650) в одной ячейке "Всего...". С одной ячейкой справляюсь (пример прилагается), а при увеличении диапазона, результат разбрасывается по смежным ячейкам. Вероятно, мой вопрос прост для вас, но я же говорю - учусь...
С уважением.
 
Простой вариант.
Вредить легко, помогать трудно.
 
Вариант.
Код
=СУММПРОИЗВ(ИНДЕКС({0;260;500;650};Ч(ИНДЕКС(ПОИСКПОЗ(A2:E2;{0;1;2;3};);))))

Но думаю, самым правильным будет сделать отдельную таблицу соответствия. Образец в примере.
Изменено: memo - 25.06.2022 07:05:25
 
массивка =SUM(IFERROR(CHOOSE(A2:E2;260;500;650);))
или просто
=SUM(COUNTIF(A3:E3;{1;2;3})*{260;500;650})
По вопросам из тем форума, личку не читаю.
 
Здравствуйте.
Спасибо. Расширили мой "кругозор". Удобней, формулами от "БМВ".
С уважением.
Страницы: 1
Читают тему (гостей: 1)
Наверх