Страницы: 1
RSS
Свой формат сокращения дней недели.
 
Приветствую!
Мне хотелось бы, чтобы "ДДД" выдавал свои собственные сокращения. В частности у меня весь файл - это чередующиеся среды и субботы. Но мне хотелось бы, чтобы ячейка выглядела не так: 22.06.2022 Ср, а вот так: 22.06.2022 Сре. И соответственно вот так: 25.06.2022 Суб. К сожалению excel предлагает только ср\сб и среда\суббота. Что я пробовал? Нашел на англ. такую формулу: =CHOOSE(WEEKDAY(A2),”Sun”,”Mon”,”Tue”,”Wed”,”Thu”,”Fri”,”Sat”). Я не знаю почему, но в русской версии программы она работает только в таком варианте: =ВЫБОР(ДЕНЬНЕД(A2);"Вс";"Пн";"Вт";"Сре";"Чт";"Пт";"Суб"), то есть вместо запятой идет точка с запятой (на это я убил пару часов, чтобы разобраться почему же оно не работало). Но проблема в том, что такая формула выдает мне только название дня недели, но мне же нужна еще и дата (25.06.2022 Суб). Тогда я попытался сделать вот такого франкенштейна: =ВЫБОР(ДЕНЬНЕД(A2);"Вс";"Пн";"Вт";"Сре";"Чт";"Пт";"Суб")*ТЕКСТ(A2;"ДД.ММ") в различных вариациях, что естесно не привело ни к какому результату.
Буду рад совету!
 
Вот пример моих попыток
 
так?

Код
=ТЕКСТ(A2;"ДД.ММ.ГГГГ")&" "&ВЫБОР(ДЕНЬНЕД(A2);"Вс";"Пн";"Вт";"Сре";"Чт";"Пт";"Суб")
 
Цитата
написал:
=ВЫБОР(ДЕНЬНЕД(A2);"Вс";"Пн";"Вт";"Сре";"Чт";"Пт";"Суб")*ТЕКСТ(A2;"ДД.ММ")
замените на
=ТЕКСТ(A2;"ДД.ММ ")&ВЫБОР(ДЕНЬНЕД(A2);"Вс";"Пн";"Вт";"Сре";"Чт";"Пт";"Суб")
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
 
ну так, чтоб было не сукчно
=TEXT(A2;"ДД.ММ."&VLOOKUP(WEEKDAY(A2);{0"ДДД";3"\Сре";4"ДДД";7"\Суб"};2))
По вопросам из тем форума, личку не читаю.
 
Цитата
БМВ написал:
ну так, чтоб было не сукчно
И еще не сукчнее )))
Код
=ТЕКСТ(A2; "ДД.ММ.ГГГ ")&ЛЕВБ(ТЕКСТ(A2; "дддд");3)

Код
=ЛЕВБ(ТЕКСТ(A2; "ДД.ММ.ГГГ ДДДД");14)
Изменено: _Boroda_ - 28.06.2022 10:18:18
Скажи мне, кудесник, любимец ба’гов...

 
Цитата
написал:
так?

Код
    [URL=#]?[/URL]       1      =ТЕКСТ(A2;  "ДД.ММ.ГГГГ"  )&  " "  &ВЫБОР(ДЕНЬНЕД(A2);  "Вс"  ;  "Пн"  ;  "Вт"  ;  "Сре"  ;  "Чт"  ;  "Пт"  ;  "Суб"  )   
 
Спасибо большое всем! Вот это взял для себя, то что нужно и то, что я лично понял как работает xD
Но всем спасибо!
 
Андрей, вы полагаете, что ваша цитата помогает определить, кому вы отвечаете?
Еще Остап Ибрагимович Берта Мария Бендер Бей  излагал -"контора пишет"!
 
RAN, ну так я только нажал кнопку под сообщением, а дальше все зависит от форума. Почему его функционал не позволил сделать все аккуратно и красиво - вопрос не ко мне  ;)
А ответ был от пользователя mechanix 85, если что. Но все равно спасибо всем!
Страницы: 1
Читают тему (гостей: 1)
Наверх