Страницы: 1
RSS
СЧЕТЕСЛИ, но пересечение не диапазона и критерия, а диапазона и диапазона
 
Добрый день.
Подскажите можно ли реализовать без VBA вывод в ячейке количества раз, когда пересекаются значения в диапазонах ячеек

Мне бы помогло СЧЕТЕСЛИ, если бы оно просто понимало Диапазон + Диапазон, а оно требует Диапазон + Ячейка.
А поскольку мне нужно пересечение между диапазоном и диапазоном - то эта формула не работает.

Пример предполагаемой работы прикладываю.

Это реально? Может я функцию неправильно выбрал?
В сторону счетеслимн - смотрел, но формула выйдет огромная, а также у нее какие-то странные требования к обязательности и необязательности условий, а мне именно сколько пересечений нужно.

Спасибо
 
shlackbaum,
формула массива, вводится с помощью cnтrl +shifт +enтer
Код
=СУММ(СЧЁТЕСЛИ(A2:A6;D2:D5))
 
формула массива:
Код
=СУММ(--(D2:H2=$A$2:$A$6))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
=SUMPRODUCT(COUNTIF($A$2:$A$10;$D2:$H2))
Только уберите пробел после помидоров в диапазоне 2
 
memo, Ігор Гончаренко, evgeniygeo, Спасибо огромное! Работает!
Страницы: 1
Читают тему (гостей: 1)
Наверх