Страницы: 1
RSS
Сложить цифры, Сложить все цифры содержащиеся в ячейке
 
Как сложить все имеющиеся цифры в ячейке,если в ней находятся ещё другие символы?
 
Код
Function SumDgt(s$)
  Dim re, ms, i&
  Set re = CreateObject("VBScript.RegExp"): re.Pattern = "\d": re.Global = True
  If re.test(s) Then Set ms = re.Execute(s) Else Exit Function
  For i = 0 To ms.Count - 1: SumDgt = SumDgt + Val(ms(i)): Next
End Function
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
happy red написал:
цифры
Цифры или числа?
Если цифры, то можно так:
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(A1;СТРОКА($1:$20);1);0))
Изменено: Msi2102 - 06.07.2022 13:40:16
 
я складывал цифры)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цифры.
Код
=SUMPRODUCT(--MID(SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(A1;"/";);"=";);"*";);"-";);" ";);ROW($A$1:INDEX($A:$A;LEN(SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(A1;"/";);"=";);"*";);"-";);" ";))));1))

Цифры и числа.
Код
=SUMPRODUCT(FILTERXML("<j><i>"&SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(A1;"=";"/");"*";"/");"-";"/");"/";"</i><i>")&"</i></j>";"//i[.*0=0]"))
 
цифры
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(A1;ПОСЛЕД(ДЛСТР(A1));1)*(КОДСИМВ(ПСТР(A1;ПОСЛЕД(ДЛСТР(A1));1))>=48)*(КОДСИМВ(ПСТР(A1;ПОСЛЕД(ДЛСТР(A1));1))<=57);0))
 
Все что-то складывают, но всеж что под
Цитата
happy red написал:
Сложить цифры
подразумевал TC????
Если складывать именно цифры, то достаточно удалить все символы между. Если складывать числа состоящие из одной цифры, то .....
По вопросам из тем форума, личку не читаю.
 
и в конце концов можно просто сложить (сосчитать сумму) всех цифр, которые есть в тексте)
(русский язык это вполне допускает)
Изменено: Ігор Гончаренко - 08.07.2022 09:22:42
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Страницы: 1
Читают тему (гостей: 1)
Наверх