Страницы: 1
RSS
СЧЕТЕСЛИ если есть хотя-бы одно значение в нескольких столбцах
 
Помогите, чё-т туплю...(может уже в отпуск пора  :)  )
Нужно формулой посчитать количество сотрудников, у которых в квартале (полугодии) есть хотя-бы одна галка
Спасибо
Согласие есть продукт при полном непротивлении сторон.
 
формула массива:
Код
=СЧЁТ(ЕСЛИ(ЛЕВБ(C2:C13&D2:D13&E2:E13)="a";СТРОКА(C2:C13)))
один из вариантов (за 1 кв.)
 
Sanja, доп. столбцы, как варриант
Изменено: Ivan.kh - 11.07.2013 19:07:06
 
=СУММ(--(МУМНОЖ(--(C2:E13="a");{1:1:1})>0))

=СУММ(--(МУМНОЖ(--(C2:H13="a");{1:1:1:1:1:1})>0))
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Ребята, спасибо! Буду разбираться.
Nic70y, так и не понял что такое ЛЕВБ (наверное опечатка)
Ivan.kh, к сожалению с доп.столбцами не вариант (сам так сделал). Все равно спасибо огромное
Владимир, МУМНОЖ то что нужно, спасибо.

Еще раз всем спасибо
Согласие есть продукт при полном непротивлении сторон.
 
если потребуется год, либо любое другое произвольное количество месяцев, формула массива:
Код
=СУММ(Ч(МУМНОЖ(Ч(C2:N13<>"");ТРАНСП(СТОЛБЕЦ(C2:N13))^0)>0))
 
MCH, спасибо, точно понадобится  :)
Согласие есть продукт при полном непротивлении сторон.
 
Цитата
Sanja пишет:
что такое ЛЕВБ
 
Nic70y, в 2010-м нет такой функции. может что-то подключить нужно?
Согласие есть продукт при полном непротивлении сторон.
 
На скрине не видно концовку. Исправим ситуацию))
===
Важно.   Функция ЛЕВБ отсчитывает по два байта на каждый символ, только если языком по умолчанию является язык с поддержкой двухбайтовой кодировки. В противном случае функция ЛЕВБ работает так же, как функция ЛЕВСИМВ, и отсчитывает по одному байту на каждый символ.

К языкам, поддерживающим двухбайтовую кодировку, относятся японский, китайский (упрощенное письмо), китайский (традиционное письмо) и корейский.
 
массив:

=СУММ((НЕ(СЦЕПИТЬ(C2:C13;D2:D13;E2:E13)=""))*1)
 
Юрий М, futurama3000, спасибо[B]
Согласие есть продукт при полном непротивлении сторон.
Страницы: 1
Читают тему (гостей: 1)
Наверх