Страницы: 1
RSS
Возможно ли увеличить количество условий чему равна ячейка в функции ЕСЛИ
 
Имеется такая формула
Код
=ЕСЛИ(ПСТР(A2;5;2)="74";ПСТР(A2;5;2)=ПСТР(D2;4;2);ПРАВСИМВ(A2;4)=ПРАВСИМВ(D2;4)) 
хотелось бы добавить перечень условий вот сюда =ЕСЛИ(ПСТР(A2;5;2)="74":"75":"73"
чет у меня не получается придумать как добавить или какую другую формулу создать
Еще забыл спросить возможно ли использовать тут условие любых значений а именно "?" пример 74??, 757?
Изменено: seregeyss - 09.02.2014 01:22:56 (забыл че хотел)
Лень двигатель прогресса, доказано!!!
 
Цитата
(забыл че хотел)...
Поскольку мало что понял,то ,может, сделать выборки в доп поля и по ним сверяться?.. Или присмотреться к связке =ЕСЛИ =И =ИЛИ?
Подстановочные знаки "*" - много и "?" - один не всегда выручают, смотреть по ситуации надо.
Количество если зависит от версии XL'я.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Эксель 2007 суть проверки есть коды в которых последние 4 знака должны быть идентичными а есть коды в которых разрешено последние 2 знака равные 0 детализировать например 7400 можно детализировать 7401 или 7456, или другой пример 7570 исходный может быть детализирован только по последнему знаку 7573
Лень двигатель прогресса, доказано!!!
 
Z, спасибо за толчек в сторону ИЛИ частично победил проблему по условию но все равно хотелось бы услышать про использование подстановочных знаков так как можно было бы ужесточить проверку в моем случае
Лень двигатель прогресса, доказано!!!
 
Цитата
seregeyss пишет:
хотелось бы услышать про использование подстановочных знаков
Яндекс и Гугл уже закрыли  ;)  ? Вот. Да и самому-бы методом проб и ошибок  ;)
Согласие есть продукт при полном непротивлении сторон.
 
Sanja, гугл не закрывали знаю как их использовать но почему то в вышеуказанной формуле они не хотят срабатывать ставлю отбор 4 знаков даю условие "74??" пишет ложь хоть ты тресни
Лень двигатель прогресса, доказано!!!
 
по моей ссылке



про ЕСЛИ к сожалению не сказано
Согласие есть продукт при полном непротивлении сторон.
 
вот почему такая несправедливость  :cry:
Лень двигатель прогресса, доказано!!!
 
с сайта http://www.programmersforum.ru/ от пользователя IgorGo
Цитата
речь не о функции ЕСЛИ, а о работе операторов сравнения >, <, =, <>.
в работе операторов сравнения подстановочные знаки не используются. * в сравниваемом значении значит * и ничего больше.
напишите в любую ячейку ="А" = "*" - получите ЛОЖЬ, т.е. не равны они.
но =ПОИСК("*";"А") - вернет 1 потому что внутри функции ПОИСК значения будут сравниваться не оператором = (равно), а оператором типа LIKE (похоже). т.е. "*" в строке "А" нашлась в первой позиции, т.е. что-нибудь найдется в любой строке, если эта строка не пустая.
вот так
Согласие есть продукт при полном непротивлении сторон.
 
спасибо что потратил время ссылки полезны на такое разяснение я не натыкался буду чето мудрить с формулой исходя из открывшихся обстоятельств
Спасибо ответившим тема закрыта
Лень двигатель прогресса, доказано!!!
 
Код
=ЕЧИСЛО(ПОИСК(ПСТР(A2;5;2);737475))
особо не вникал в тему (уж больно много сообщений, текста) :(
может эта формула сгодиться?
 
seregeyss, покажите, что хотите получить в итоге.
=ЕСЛИ(n-ые знаки равны "74";то n-ые знаки A3=n-ным знакам D3;  и пр. лабуда.) Плюньте на формулы, человеческим языком объясните, что нужно? Что такое "детализирован"? 215 сообщений - пора уже выражать мысли грамотно.
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Цитата
Владимир пишет:
215 сообщений - пора уже выражать мысли грамотно.
Офф.
к сожалению от количества сообщений это не зависит
Страницы: 1
Читают тему (гостей: 1)
Наверх