Страницы: 1
RSS
Нахождение суммы в массиве данных с условием по строкам и столбцам.
 
Добрый день, друзья.
Вопрос, может, элементарнейший, но поставил меня в тупик, а его решение уже нужно.

Жена на работе создала огромнейшую таблицу, которую уже необходимо реализовывать в более совершенных инструментах, но не об этом разговор.
В одной из ее таблиц есть необходимость выдавать сумму из массива по определенным условиям (все условия в одной горизонтальной строке), что само по себе проблем не составляет, проблема для меня начинается, когда необходимо суммировать значения по столбцу в зависимости от месяца, который в исходной форме указывается в столбце.

Объяснение путанное, прикладываю часть из этой таблицы с необходимыми данными.
Спасибо за внимание.
 
ничего не понял. что должно получиться отметьте в файле
 
Код
=СУММЕСЛИМН(ИНДЕКС(Исходная!$1:$1048576;1;ПОИСКПОЗ($D2;Исходная!$1:$1;0)):ИНДЕКС(Исходная!$1:$1048576;ЧСТРОК(Исходная!$1:$1048576);ПОИСКПОЗ($D2;Исходная!$1:$1;0));Исходная!$B:$B;$A2;Исходная!$A:$A;$B2;Исходная!$C:$C;$E2)

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Цитата
то в зависимости от месяца посчитать сумму
мне вот это не понятно. в файле пару расчетов вручную изобразите. если вдруг JayBhagavan не угадал. :)
 
{=СУММ(ЕСЛИ($C16=Поставщик;1;0)*ЕСЛИ(D$15=Период;1;0)*МассивДанных)}
ФМ
 
Прошу прощения за путанное объяснение, но Евгений Кириллов сделал именно то, что мне было необходимо.

Спасибо огромное всем, кто ответил!
 
тогда так попроще и красивше  :)
Код
=СУММПРОИЗВ((Поставщик=$C16)*(Период=D$15)*МассивДанных) 
Страницы: 1
Читают тему (гостей: 1)
Наверх