Страницы: 1
RSS
Вставка данных в надстройку
 
Добрый день, господа!
Разобрался с созданием собственной надстройки, с ее вызовом и оформлением в ribbon. Все хорошо, но часть функций завязана на формуле ВПР. В частности функция берет значение из файла и лезет в другой (закрытый) файл-хранилище, и берет оттуда данные. Но надстройка распространяется между коллегами, и приходится вместе с ней, передавать и файл-хранилище, и класть по такому же пути, чтобы не править пути на каждом компьютере. Вопрос:
Можно ли как то занести данные из файла-хранилища в тело надстройки, и ссылаться на нее?
 
А в чем проблема-то? Ну скопируйте лист(ы) с данными из хранилища в надстройку и пользуйтесь на здоровье.
 
А каким образом? Т.е если открыть надстройку двойным кликом, добавить в нее листы я не могу. Когда открываю файл-хранилище, и в редакторе VB пытаюсь скопировать лист -  не получается. Формы, классы и т.д - копируются, а листы - нет.
Изменено: kobzargv - 11.12.2014 16:35:35
 
В редакторе или кодом поменяйте ей свойство isaddin на false, добавьте листы, поменяйте назад.
 
Снимите признак надстройки, перенесите лист, установите признак обратно.
 
Готово! Спасибо!  
 
Теперь при открытии любой книги, просит обновить связи. Но данные то в пределах надстройки? Формула имеет вид  "=ВПР(A2;'[WORK.xlam]sendsheet'!$C$2:$F$500;4;0)" Полный путь не нужен, если убираю [work.xlam], то при инициации функции открывается окно поиска этого файла.  
Изменено: kobzargv - 11.12.2014 17:35:06
 
В самой надстройке разорвите все связи, которые были прописаны, и поменяйте ссылки на внутренние данные.
 
Все поменяно, описал выше
 
Показать файл можете?
 
Разобрался, не там удалил связи. Спасибо за помощь!
Страницы: 1
Читают тему (гостей: 1)
Наверх