Страницы: 1
RSS
Суммирование по месяцу
 
пользуясь оператором суммесли суммирую ячейки ...получилось нечто вроде
=суммесли(месяц(а1;а10);4;b1:b10)
и выдает ошибку
 
Цитата
Slow пишет: ..получилось нечто вроде
Может не будем разводить?!
"2.2. Опишите максимально подробно вашу задачу и желаемый результат. Желательно уточнить вашу версию Excel.
2.3. Приложите файл(ы) с примером (общим весом не более 100 Кб) в реальной структуре и форматах данных того, что есть сейчас и того, что хотелось бы на выходе. "
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
итак....задача
подсчет ананасов отгруженных в конкретный месяц

в данном файле показал как можно сделать разбив все по действиям
 
Сводная по ана_насам...
Off ;)  Как это было однажды: "Мы с ней?- Нет! Она с нами? -Нет! А как же? - Она нас!"
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
) проблема была не в решении а в применении формулы...
хотелось бы осознать как применяется привязка месяца и суммы в одном действии  
 
дополнение для многозадачности ...те
для одной задачи = суммесли
для многих = суммеслимн
задание- рассчитать поставку ананасов совершенную в долларах в январе )
Изменено: Slow - 14.12.2014 14:28:28
 
Цитата
Slow пишет: дополнение для...
Цитата
задание- рассчитать...
Вот как созреет реальная хотелка на реальном файле, а пока  - Пока!.. (выходной однако, а не тренинг)   ;)
ps А задания могут решить за вас - на заказ, в "Работе".
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
к сожалению это вопрос интереса а не работы, как что вклинится в голову, а потом не могу спать и есть ...прям как лубов )
спасибо за проявленный интерес  ;)
 
итак...думаю проблема заключается в невозможности экселя использовать данные и вынести решение
была составлена формула =СУММЕСЛИ(месяц(A2);месяц(J4);B2)
где месяцы совпадали. Таблица функций показала что  значения месяцев совпали, однако ответа истина или ложь не было )

возможно я неправ и есть умельцы от бога которые докажут что это не так )

П.с
раз уж от бога - то назначаю вознаграждение (чисто символическое)  - 100 нашинских рублев  
Изменено: Slow - 14.12.2014 15:17:03
 
Код
=СУММПРОИЗВ((МЕСЯЦ(A2:A400)=1)*(C2:C400="usd")*B2:B400)
 
 
СУММЕСЛИ работает только с прямой ссылкой на диапазоны листа, обработка диапазонов - это уже другое.
Выход: или вариант SkyPro, или доп. столбец и уже по нему СУММЕСЛИ или СУММЕСЛИМН
 
спасибо, проверку сделал - все верно, жду сообщения от SkyPro
спасибо администратору за разъяснение  
 
Цитата
Slow пишет: жду сообщения от SkyPro
Да какое сообщение? Я то и вопроса не понял.
 
 выкладывай номер телефона в лс  8[
 
Цитата
Slow пишет:
выкладывай номер телефона в лс
Вот как раз это и нужно писать в ЛС.
Страницы: 1
Читают тему (гостей: 1)
Наверх